Bug 145962 - 32-bit libstdc++.so.5 missing, needed by 32-bit firefox
32-bit libstdc++.so.5 missing, needed by 32-bit firefox
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: compat-libs (Show other bugs)
4.0
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-24 08:37 EST by tim murphy
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-24 08:47:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tim murphy 2005-01-24 08:37:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; 
H010818)

Description of problem:
Need 32-bit browser to run 32-bit binary plugins.  Mozilla 1.7 
installs fine, but cannot install FireFox 1.0 due to dependency 
on /usr/lib/libstdc++.so.5

Note /usr/lib64/libstdc++.so.5 is installed as part of the compat-
libstdc++ package, but not the 32-bit version

Version-Release number of selected component (if applicable):
compat-libstdc++-33-3.2.3-46.1

How reproducible:
Always

Steps to Reproduce:
1. download 32-bit FireFox binary
2. run its install package: ./firefox-installer
3. observe error


Actual Results:  ./firefox-installer-bin: error while loading shared 
libraries: libstdc++.so.5: cannot open shared object file: no such 
file or directory
    

Expected Results:  successfully installed

Additional info:

low severity due to workaround avail. (install 32-bit mozilla 1.7)
Comment 1 Jakub Jelinek 2005-01-24 08:47:36 EST
/usr/lib/libstdc++.so.5 is also installed as part of compat-libstdc++-33 rpm.

ls -l RedHat/RPMS/compat-libstdc++-*
-rw-r--r--   62 root     root       180344 Jan  5 17:04
RedHat/RPMS/compat-libstdc++-296-2.96-132.7.2.i386.rpm
-rw-r--r--   62 root     root       231823 Jan  5 17:04
RedHat/RPMS/compat-libstdc++-33-3.2.3-47.3.i386.rpm
-rw-r--r--   25 root     root       228988 Jan  5 17:04
RedHat/RPMS/compat-libstdc++-33-3.2.3-47.3.x86_64.rpm
rpm -qplv RedHat/RPMS/compat-libstdc++-33-3.2.3-47.3.i386.rpm | grep
libstdc++.so.5
lrwxrwxrwx    1 root    root               18 Dec  1 11:12
/usr/lib/libstdc++.so.5 -> libstdc++.so.5.0.7
-rwxr-xr-x    1 root    root           733488 Dec  1 11:12
/usr/lib/libstdc++.so.5.0.7

Note You need to log in before you can comment on or make changes to this bug.