Bug 1459653 - missing dependency of package gajim: gnome-python2-gnome
missing dependency of package gajim: gnome-python2-gnome
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gajim (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Schmidt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 13:31 EDT by ben_redhat
Modified: 2017-06-30 06:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-30 06:09:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ben_redhat 2017-06-07 13:31:41 EDT
Description of problem:
Installing gajim does not automatically install package 'gnome-python2-gnome'. It is required though:

```
gajim.py:487: ImportWarning: Not importing directory '/usr/lib64/python2.7/site-packages/gtk-2.0/gnome': missing __init__.py
  import gnome.ui
```

Version-Release number of selected component (if applicable):
gajim 0.16.7-1.fc25

How reproducible:
Always

Steps to Reproduce:
1. make sure gnome-python2-gnome is not installed
2. install Gajim

Actual results:
gnome-python2-gnome is not installed automatically

Expected results:
gnome-python2-gnome should be installed

Additional info:
Comment 1 Michal Schmidt 2017-06-14 08:05:11 EDT
I can reproduce the ImportWarning message, but Gajim starts and works anyway.
Are you seeing any loss of functionality?
A comment in the code says the import is for session management. This is non-essential functionality. I'd prefer to avoid a hard dependency for this.
Comment 2 ben_redhat 2017-06-14 13:21:58 EDT
(In reply to Michal Schmidt from comment #1)
> I can reproduce the ImportWarning message, but Gajim starts and works anyway.
> Are you seeing any loss of functionality?
> A comment in the code says the import is for session management. This is
> non-essential functionality. I'd prefer to avoid a hard dependency for this.

I reported this because I thought it was the reason I could not simply install the omemo plugin - but it turns out that that was because the plugin-installer plugin is not installed per default on fedora (and in fact not packaged at all). So no, I did not notice any problems even with the warning.
Comment 3 Michal Schmidt 2017-06-30 06:09:13 EDT
The plugin installer should be working again in gajim-0.16.8-1.fc25. The reason it was broken in 0.16.7 was a mistake done by the upstream Gajim developers when creating the tarball. Later they realized the mistake and respun the tarball, but I had already packaged the original one without noticing the problem.

The OMEMO plugin can be installed, but it does not run. It is due to missing python-axolotl in Fedora. It seems the package reviews have been abandoned:
https://bugzilla.redhat.com/show_bug.cgi?id=1382332
https://bugzilla.redhat.com/show_bug.cgi?id=1382333

Note You need to log in before you can comment on or make changes to this bug.