Bug 1459702 - SSA cannot be performed from the UI zone
SSA cannot be performed from the UI zone
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.8.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.8.3
Assigned To: Rich Oliveri
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 18:32 EDT by Jerome Marc
Modified: 2018-07-12 13:28 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-07-12 13:28:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)

  None (edit)
Description Jerome Marc 2017-06-07 18:32:12 EDT
Description of problem:
I have a multi-appliance setup with a dedicated appliance for my OpenShift provider. When trying to start a Smart-State Analysis for container images manually from the image view, the button is not enabled and I cannot perform the operation. Similarily, I cannot schedule a SSA for container images from the appliances in the UI zone. When login in the dedicated appliance for OpenShift, all these operations are possible.

Version-Release number of selected component (if applicable):
5.8.0.17.20170525183055_6317a22

How reproducible:
Always

Steps to Reproduce:
1. Setup CF deployment with a UI zone and OpenShift zone
2. Try to perform SSA from the UI zone
3. Try to perform SSA from the OpenShift zone

Actual results:
SSA from the UI zone fails
SSA from the OpenShift zone successes

Expected results:
SSA operation on Container Images should be possible from the UI zone.

Additional info:
Comment 2 Federico Simoncelli 2017-06-08 04:24:02 EDT
This could be related to:

https://github.com/ManageIQ/manageiq-ui-classic/pull/273

Jerome, just to make sure, do you have the SmartProxy role enabled?
Comment 3 Jerome Marc 2017-06-08 12:08:46 EDT
I should not have to enable SmartProxy or SmartState Analysis roles on the UI Zone. That being said, I enabled it in the environment and got the same results.
Comment 4 Federico Simoncelli 2017-06-08 12:10:58 EDT
(In reply to Jerome Marc from comment #3)
> I should not have to enable SmartProxy or SmartState Analysis roles on the
> UI Zone. That being said, I enabled it in the environment and got the same
> results.

Yes I didn't mean in the UI Zone, I meant on the OpenShift appliance Zone.

Anyway it's good to know that even with that enabled in the UI zone it is still not working.
Comment 5 Erez Freiberger 2017-06-08 12:18:16 EDT
Those roles are needed regardless of the graying of the button to complete the SSA.
It is worth to give it time to update and refresh the image page, I have seen that it might take some time for the roles to update.
Comment 6 Federico Simoncelli 2017-06-13 08:49:42 EDT
Erez I have the feeling that Jerome took his time to refresh the image page.

What other information do you need from him to move this forward?
Maybe you can do a session with him.
Comment 7 Erez Freiberger 2017-06-18 08:17:38 EDT
The button checks that for each required role there is a server in the current zone with that role. AFAIU - If there aren't the scan won't complete anyway [1].

It seems that a live session will be very helpful to understand the problem.

[1]https://github.com/ManageIQ/manageiq-ui-classic/pull/273#pullrequestreview-19094216
Comment 8 Dave Johnson 2017-07-13 23:47:59 EDT
Please assess the importance of this issue and update the priority accordingly.  Somewhere it was missed in the bug triage process.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#priority for a reminder on each priority's definition.

If it's something like a tracker bug where it doesn't matter, please set it to Low/Low.
Comment 9 Federico Simoncelli 2017-08-22 06:52:30 EDT
Jerome is this issue still present / reproducible?
Comment 10 Jerome Marc 2017-08-23 11:50:56 EDT
Yes, still an issue on CFME 5.8.1
Comment 11 Federico Simoncelli 2017-08-23 12:49:58 EDT
(In reply to Jerome Marc from comment #10)
> Yes, still an issue on CFME 5.8.1

Jerome can you organize a debugging session with Erez? It seems we're not able to reproduce, it's probably something really peculiar in your environment.
Comment 20 Jeff Warnica 2017-10-26 17:03:22 EDT
Possible dup of https://bugzilla.redhat.com/show_bug.cgi?id=1439735

Note You need to log in before you can comment on or make changes to this bug.