Bug 1459766 - perl-Cflow-1.053-33.fc26 FTBFS on 32-bit platforms: Cflow.c: loadable library and perl binaries are mismatched
perl-Cflow-1.053-33.fc26 FTBFS on 32-bit platforms: Cflow.c: loadable library...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Cflow (Show other bugs)
26
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-08 03:01 EDT by Petr Pisar
Modified: 2017-06-13 09:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-Cflow-1.053-35.fc27 perl-Cflow-1.053-34.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-13 09:35:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2017-06-08 03:01:07 EDT
perl-Cflow-1.053-33.fc26 fails to build on 32-bit platforms (i686, armv7hl). The tests fails there:

+ make test
"/usr/bin/perl" -MExtUtils::Command::MM -e 'cp_nonempty' -- Cflow.bs blib/arch/auto/Cflow/Cflow.bs 644
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-Iblib/lib" "-Iblib/arch" test.pl
1..1
Cflow.c: loadable library and perl binaries are mismatched (got handshake key 0x7e00080, needed 0x7f00080)
make: *** [Makefile:988: test_dynamic] Error 1

This is caused by bad compiler invocation. The gcc is missing "-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" options. That makes data structures incompatible with how libperl.so is built. This points to poor Cflow build script that looses $Config{ccflags} value.
Comment 1 Fedora Update System 2017-06-08 03:55:54 EDT
perl-Cflow-1.053-34.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9089de7482
Comment 2 Petr Pisar 2017-06-08 04:02:15 EDT
Four you information, the problem was "use Config;" was missing in Makefile.PL. And because it does not enable warnings, undefined $Config{ccflags} expanded silently to an empty string.
Comment 3 Orion Poplawski 2017-06-08 12:30:38 EDT
Thanks Petr!  I had not been able to figure this one out.
Comment 4 Fedora Update System 2017-06-09 21:09:13 EDT
perl-Cflow-1.053-34.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9089de7482
Comment 5 Fedora Update System 2017-06-13 09:35:44 EDT
perl-Cflow-1.053-34.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.