Bug 1459934 - Fedora 25 to 26 beta does not upgrade python-requests package
Fedora 25 to 26 beta does not upgrade python-requests package
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-requests (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Infrastructure SIG
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-08 11:27 EDT by Miguel Perez Colino
Modified: 2017-06-09 08:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-09 08:59:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miguel Perez Colino 2017-06-08 11:27:39 EDT
Description of problem:
Upgrade does np

Version-Release number of selected component (if applicable):
From Fedora 25 to Fedora 26 beta

How reproducible:
Upgrade Fedora 25 to 26 beta using:
# dnf system-upgrade download --releasever=26 --setopt=deltarpm=false --refresh --allowerasing

Actual results:
https://bugzilla.redhat.com/show_bug.cgi?id=1459100

Expected results:
virt-manager running

Additional info:
This solved it
[root@hal:~]# mv /usr/lib/python2.7/site-packages/requests /usr/lib/python2.7/site-packages/requests_old

[mperezco@hal:~# dnf install python-requests --best --allowerasing
Last metadata expiration check: 1:13:05 ago on Thu Jun 08 15:52:18 2017 CEST.
Package python2-requests-2.10.0-4.fc25.noarch is already installed, skipping.
Dependencies resolved.
================================================================================
 Package                 Arch          Version              Repository     Size
================================================================================
Upgrading:
 python2-requests        noarch        2.13.0-1.fc26        fedora        116 k

Transaction Summary
================================================================================
Upgrade  1 Package

Total download size: 116 k
Is this ok [y/N]: y
Downloading Packages:
python2-requests-2.13.0-1.fc26.noarch.rpm       491 kB/s | 116 kB     00:00    
--------------------------------------------------------------------------------
Total                                            99 kB/s | 116 kB     00:01     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Upgrading        : python2-requests-2.13.0-1.fc26.noarch                  1/2 
  Cleanup          : python2-requests-2.10.0-4.fc25.noarch                  2/2 
warning: file /usr/lib/python2.7/site-packages/requests-2.10.0-py2.7.egg-info/top_level.txt: remove failed: No such file or directory
warning: file /usr/lib/python2.7/site-packages/requests-2.10.0-py2.7.egg-info/requires.txt: remove failed: No such file or directory
warning: file /usr/lib/python2.7/site-packages/requests-2.10.0-py2.7.egg-info/not-zip-safe: remove failed: No such file or directory
warning: file /usr/lib/python2.7/site-packages/requests-2.10.0-py2.7.egg-info/dependency_links.txt: remove failed: No such file or directory
warning: file /usr/lib/python2.7/site-packages/requests-2.10.0-py2.7.egg-info/SOURCES.txt: remove failed: No such file or directory
warning: file /usr/lib/python2.7/site-packages/requests-2.10.0-py2.7.egg-info/PKG-INFO: remove failed: No such file or directory
warning: file /usr/lib/python2.7/site-packages/requests-2.10.0-py2.7.egg-info: remove failed: No such file or directory
  Verifying        : python2-requests-2.13.0-1.fc26.noarch                  1/2 
  Verifying        : python2-requests-2.10.0-4.fc25.noarch                  2/2 

Upgraded:
  python2-requests.noarch 2.13.0-1.fc26
Comment 1 Zbigniew Jędrzejewski-Szmek 2017-06-08 11:58:49 EDT
This is clearly some missing dependency or other bug (see https://bugzilla.redhat.com/show_bug.cgi?id=1459100#c11) in requests. dnf-plugin-system-upgrade doesn't know anything about specific packages, it just upgrades anything and everything that it can to the new release.
Comment 2 Jeremy Cline 2017-06-09 08:59:03 EDT
It sounds like you used ``sudo pip install`` and that is not currently safe on Fedora as it steps on the dnf-installed packages. I'm going to close this as not a bug, but feel free to re-open it if you're very sure you never used ``sudo pip install``.

Note You need to log in before you can comment on or make changes to this bug.