Bug 145994 - yum src RPM builds with errors
yum src RPM builds with errors
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-24 11:38 EST by JM
Modified: 2014-01-21 17:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 00:59:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JM 2005-01-24 11:38:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When you try to rebuild yum from the src RPM you will see that during
the build process you get messages like this:

c "import compileall;
compileall.compile_dir('/var/tmp/yum-root//usr/lib/python2.3/site-packages/repomd',
1, '', 1)"
/bin/sh: c: command not found

The problem is that the line actually should look like this:

pyhton -c "import compileall;
compileall.compile_dir('/var/tmp/yum-root//usr/lib/python2.3/site-packages/repomd',
1, '', 1)"

The "python" before the "-c" is missing.



Version-Release number of selected component (if applicable):
yum-2.1.12-0.fc3.src.rpm yum-2.1.12-3.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Get yum-2.1.12-0.fc3.src.rpm or yum-2.1.12-3.src.rpm
2. rpmbuild --rebuild yum-2.1.12-0.fc3.src.rpm or yum-2.1.12-3.src.rpm
3. check the output for "/bin/sh: c: command not found"
    

Actual Results:  The result is that the .py files in the folder

/usr/lib/python2.3/site-packages/repomd,
/usr/lib/python2.3/site-packages/rpmUtils,
/usr/lib/python2.3/site-packages/urlgrabber and
/usr/lib/python2.3/site-packages/urlgrabber

are not compiled (.pyc).

yum works without the .pyc but I I think it would be better to have
the .pyc :-).

Expected Results:  The .py files in the folder

/usr/lib/python2.3/site-packages/repomd,
/usr/lib/python2.3/site-packages/rpmUtils,
/usr/lib/python2.3/site-packages/urlgrabber and
/usr/lib/python2.3/site-packages/urlgrabber

should compile to .pyc.
Comment 1 JM 2005-01-24 11:51:42 EST
When you compile the .py files you get for the file
/usr/lib/python2.3/site-packages/yum/transactioninfo.py" the error:

---------------
  File "transactioninfo.py", line 48
    if name is not None and arch is not None and epoch is not None and
ver is not
                                                                     
           ^
SyntaxError: invalid syntax
---------------

I assume it should be "ver is not None" instead of "ver is not".
Comment 2 Seth Vidal 2005-01-25 00:59:36 EST
both fixed in upstream cvs.

Note You need to log in before you can comment on or make changes to this bug.