Bug 1460126 - tempest.api.network.test_dhcp_ipv6.NetworksTestDHCPv6 failing
tempest.api.network.test_dhcp_ipv6.NetworksTestDHCPv6 failing
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: zstream
: 7.0 (Kilo)
Assigned To: Chandan Kumar
Martin Kopec
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-09 04:00 EDT by Bernard Cafarelli
Modified: 2017-07-12 09:16 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-tempest-kilo-20151020.2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-12 09:16:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 185616 None None None 2017-06-09 04:02 EDT

  None (edit)
Description Bernard Cafarelli 2017-06-09 04:00:19 EDT
Description of problem:

some DHCPv6 API tests fail in CI runs, like:
tempest.api.network.test_dhcp_ipv6.NetworksTestDHCPv6.test_dhcp_stateful
tempest.api.network.test_dhcp_ipv6.NetworksTestDHCPv6.test_dhcpv6_64_subnets

This upstream change fixes this problem (removing the expectation that assigned IP will be the first or second in the pool):
https://review.openstack.org/#/c/185616/

Version-Release number of selected component (if applicable):
openstack-tempest-kilo-20151020.1.el7ost

How reproducible: 100%


Steps to Reproduce:
1. Deploy RHOSP 7
2. Run Tempest API DHCP IPv6 tests

Actual results:
Traceback (most recent call last):
  File "/home/stack/tempest-dir/tempest/api/network/test_dhcp_ipv6.py", line 224, in test_dhcpv6_two_subnets
    str(dhcp_ip)))
  File "/usr/lib/python2.7/site-packages/testtools/testcase.py", line 354, in assertIn
    self.assertThat(haystack, Contains(needle), message)
  File "/usr/lib/python2.7/site-packages/testtools/testcase.py", line 433, in assertThat
    raise mismatch_error
MismatchError: u'2003:0:0:1::4' not in [u'2003:0:0:1::2', '2003:0:0:1::3']: Real IP is 2003:0:0:1::4, but shall be one from [u'2003:0:0:1::2', '2003:0:0:1::3']

Expected results: tests pass fine


Additional info: same failure was observed and fixed for newer versions (see linked bug)
Comment 1 Bernard Cafarelli 2017-06-09 04:02:05 EDT
Sorry, I misread #1384631 this is not the same bug
Comment 12 Martin Kopec 2017-06-30 03:21:32 EDT
The openstack-tempest-kilo-20151020.2.el7ost package contains backported code, so marking this as verified.
Comment 15 errata-xmlrpc 2017-07-12 09:16:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1745

Note You need to log in before you can comment on or make changes to this bug.