Bug 146014 - scons failes on x86-64
scons failes on x86-64
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: scons (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-24 13:44 EST by Thorsten Leemhuis
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 10:45:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes x86_64 problems, update minor spec-file bit (1.86 KB, patch)
2005-01-25 13:12 EST, Thorsten Leemhuis
no flags Details | Diff

  None (edit)
Description Thorsten Leemhuis 2005-01-24 13:44:50 EST
Description of problem:
The libs of scons are placed in /usr/lib64 on x86-64; scons doest not find them
there:

$ scons
Traceback (most recent call last):
  File "/usr/bin/scons", line 143, in ?
    import SCons.Script
ImportError: No module named SCons.Script

Even with exporting SCONS_LIB_DIR it does not work:

$ export SCONS_LIB_DIR=/usr/lib64/scons/
$ scons

scons: *** No SConstruct file found.
File "/usr/lib64/scons/SCons/Script/__init__.py", line 870, in _main

Version-Release number of selected component (if applicable):
scons-0.96-3 from pre-extras

Suggested resolution:
Not really sure. But so there seem to be only python-Files in /usr/lib(64)/scons
-- so why not place them in /usr/lib?
Comment 1 Michael Schwendt 2005-01-24 14:20:15 EST
Yes, installing into %{_prefix}/lib would be correct, because it is a
noarch package.
Comment 2 Thorsten Leemhuis 2005-01-25 13:12:09 EST
Created attachment 110208 [details]
fixes x86_64 problems, update minor spec-file bit

Changelog:
- Place libs in {_prefix}/lib/ and not in {libdir}; fixes x86_64 problems
- Adjust minor bits to be in sync with python-spec-template

Michael, what do you suggest: Gerald placing an update package in fedora.us
with this fixes or fix this directly in CVS?
Comment 3 Thorsten Leemhuis 2005-01-27 10:45:24 EST
Built, published.

Note You need to log in before you can comment on or make changes to this bug.