Bug 1460215 - [UPDATES] Dependecies for openwsman-python when updating RHOS-9 to RHEL-7.4 [openstack-9]
[UPDATES] Dependecies for openwsman-python when updating RHOS-9 to RHEL-7.4 [...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openwsman (Show other bugs)
9.0 (Mitaka)
Unspecified Unspecified
high Severity high
: async
: 9.0 (Mitaka)
Assigned To: Mike Burns
nlevinki
: Triaged
Depends On:
Blocks: 1460221 1470581
  Show dependency treegraph
 
Reported: 2017-06-09 07:41 EDT by Yurii Prokulevych
Modified: 2017-08-23 03:58 EDT (History)
13 users (show)

See Also:
Fixed In Version: openwsman-2.3.6-14.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1460221 (view as bug list)
Environment:
Last Closed: 2017-08-01 20:49:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yurii Prokulevych 2017-06-09 07:41:25 EDT
Description of problem:
-----------------------
Attempt to update RHOS-9 running on RHEL-7.3 fails:
...
--> Processing Dependency: libwsman1 = 2.3.6-13.el7 for package: openwsman-python-2.3.6-13.el7.x86_64
--> Finished Dependency Resolution
Error: Package: openwsman-python-2.3.6-13.el7.x86_64 (@rhelosp-9.0-director-puddle)
           Requires: libwsman1 = 2.3.6-13.el7
           Removing: libwsman1-2.3.6-13.el7.x86_64 (@rhelosp-rhel-7.3-server)
               libwsman1 = 2.3.6-13.el7
           Updated By: libwsman1-2.3.6-14.el7.x86_64 (rhelosp-rhel-7.4-server)
               libwsman1 = 2.3.6-14.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Command '['sudo', 'yum', 'update', '-y']' returned non-zero exit status 1

[root@undercloud-0 ~]# yum info libwsman1.x86_64
Loaded plugins: search-disabled-repos
Installed Packages
Name        : libwsman1
Arch        : x86_64
Version     : 2.3.6
Release     : 13.el7
Size        : 314 k
Repo        : installed
From repo   : rhelosp-rhel-7.3-server
Summary     : Open source Implementation of WS-Management
URL         : http://www.openwsman.org/
License     : BSD
Description : Openwsman library for packages dependent on openwsman

Available Packages
Name        : libwsman1
Arch        : x86_64
Version     : 2.3.6
Release     : 14.el7
Size        : 125 k
Repo        : rhelosp-rhel-7.4-server/x86_64
Summary     : Open source Implementation of WS-Management
URL         : http://www.openwsman.org/
License     : BSD
Description : Openwsman library for packages dependent on openwsman



Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openwsman-python-2.3.6-13.el7.x86_64
openstack-tripleo-heat-templates-liberty-2.0.0-49.el7ost.noarch
openstack-tripleo-heat-templates-2.0.0-49.el7ost.noarch

Steps to Reproduce:
-------------------
1. Deploy RHOS-9 (director 2017-05-05.2, build 2017-05-05.1)
2. Setup latest repos (director 2017-06-01.1, build 2017-05-31.1, RHEL-7.4 repo)
3. Try update uc
Comment 2 Lukas Bezdicka 2017-06-12 08:34:16 EDT
[root@undercloud ~]# yum update libwsman1*
Loaded plugins: search-disabled-repos
Resolving Dependencies
--> Running transaction check
---> Package libwsman1.x86_64 0:2.3.6-13.el7 will be updated
--> Processing Dependency: libwsman1 = 2.3.6-13.el7 for package: openwsman-python-2.3.6-13.el7.x86_64
---> Package libwsman1.x86_64 0:2.3.6-14.el7 will be an update
--> Running transaction check
---> Package libwsman1.i686 0:2.3.6-13.el7 will be installed
--> Processing Dependency: libc.so.6 for package: libwsman1-2.3.6-13.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: libwsman1-2.3.6-13.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: libwsman1-2.3.6-13.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.1) for package: libwsman1-2.3.6-13.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: libwsman1-2.3.6-13.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: libwsman1-2.3.6-13.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: libwsman1-2.3.6-13.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: libwsman1-2.3.6-13.el7.i686
--> Processing Dependency: libcurl.so.4 for package: libwsman1-2.3.6-13.el7.i686
--> Processing Dependency: libdl.so.2 for package: libwsman1-2.3.6-13.el7.i686
--> Processing Dependency: libpthread.so.0 for package: libwsman1-2.3.6-13.el7.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.0) for package: libwsman1-2.3.6-13.el7.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.1) for package: libwsman1-2.3.6-13.el7.i686
--> Processing Dependency: libxml2.so.2 for package: libwsman1-2.3.6-13.el7.i686
--> Processing Dependency: libxml2.so.2(LIBXML2_2.4.30) for package: libwsman1-2.3.6-13.el7.i686
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.0) for package: libwsman1-2.3.6-13.el7.i686
---> Package libwsman1.x86_64 0:2.3.6-13.el7 will be updated
--> Running transaction check
---> Package glibc.x86_64 0:2.17-157.el7_3.2 will be updated
--> Processing Dependency: glibc = 2.17-157.el7_3.2 for package: glibc-common-2.17-157.el7_3.2.x86_64
--> Processing Dependency: glibc = 2.17-157.el7_3.2 for package: glibc-devel-2.17-157.el7_3.2.x86_64
--> Processing Dependency: glibc = 2.17-157.el7_3.2 for package: glibc-headers-2.17-157.el7_3.2.x86_64
---> Package glibc.i686 0:2.17-194.el7 will be installed
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-194.el7.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-194.el7.i686
---> Package glibc.x86_64 0:2.17-194.el7 will be an update
---> Package libcurl.x86_64 0:7.29.0-35.el7 will be updated
--> Processing Dependency: libcurl = 7.29.0-35.el7 for package: curl-7.29.0-35.el7.x86_64
---> Package libcurl.i686 0:7.29.0-42.el7 will be installed
--> Processing Dependency: libssh2(x86-32) >= 1.4.3 for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libcom_err.so.2 for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libgssapi_krb5.so.2 for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libgssapi_krb5.so.2(gssapi_krb5_2_MIT) for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libidn.so.11 for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libidn.so.11(LIBIDN_1.0) for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libk5crypto.so.3 for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libkrb5.so.3 for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: liblber-2.4.so.2 for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libldap-2.4.so.2 for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libnspr4.so for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libnss3.so for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libnss3.so(NSS_3.10) for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libnss3.so(NSS_3.12) for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libnss3.so(NSS_3.12.1) for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libnss3.so(NSS_3.12.5) for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libnss3.so(NSS_3.2) for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libnss3.so(NSS_3.3) for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libnss3.so(NSS_3.4) for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libnss3.so(NSS_3.5) for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libnss3.so(NSS_3.9.2) for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libnss3.so(NSS_3.9.3) for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libnssutil3.so for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libplc4.so for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libplds4.so for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libsmime3.so for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libssh2.so.1 for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libssl3.so for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libssl3.so(NSS_3.11.4) for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libssl3.so(NSS_3.14) for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libssl3.so(NSS_3.2) for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libssl3.so(NSS_3.4) for package: libcurl-7.29.0-42.el7.i686
--> Processing Dependency: libz.so.1 for package: libcurl-7.29.0-42.el7.i686
---> Package libcurl.x86_64 0:7.29.0-42.el7 will be an update
---> Package libxml2.i686 0:2.9.1-6.el7_2.3 will be installed
--> Processing Dependency: liblzma.so.5 for package: libxml2-2.9.1-6.el7_2.3.i686
--> Processing Dependency: liblzma.so.5(XZ_5.0) for package: libxml2-2.9.1-6.el7_2.3.i686
--> Running transaction check
---> Package curl.x86_64 0:7.29.0-35.el7 will be updated
---> Package curl.x86_64 0:7.29.0-42.el7 will be an update
---> Package glibc-common.x86_64 0:2.17-157.el7_3.2 will be updated
---> Package glibc-common.x86_64 0:2.17-194.el7 will be an update
---> Package glibc-devel.x86_64 0:2.17-157.el7_3.2 will be updated
---> Package glibc-devel.x86_64 0:2.17-194.el7 will be an update
---> Package glibc-headers.x86_64 0:2.17-157.el7_3.2 will be updated
---> Package glibc-headers.x86_64 0:2.17-194.el7 will be an update
---> Package krb5-libs.x86_64 0:1.14.1-27.el7_3 will be updated
---> Package krb5-libs.i686 0:1.15.1-8.el7 will be installed
--> Processing Dependency: libcrypto.so.10 for package: krb5-libs-1.15.1-8.el7.i686
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10) for package: krb5-libs-1.15.1-8.el7.i686
--> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.15.1-8.el7.i686
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.15.1-8.el7.i686
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_1.0) for package: krb5-libs-1.15.1-8.el7.i686
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_1.5) for package: krb5-libs-1.15.1-8.el7.i686
--> Processing Dependency: libselinux.so.1 for package: krb5-libs-1.15.1-8.el7.i686
--> Processing Dependency: libssl.so.10 for package: krb5-libs-1.15.1-8.el7.i686
--> Processing Dependency: libssl.so.10(libssl.so.10) for package: krb5-libs-1.15.1-8.el7.i686
--> Processing Dependency: libverto.so.1 for package: krb5-libs-1.15.1-8.el7.i686
---> Package krb5-libs.x86_64 0:1.15.1-8.el7 will be an update
---> Package libcom_err.x86_64 0:1.42.9-9.el7 will be updated
--> Processing Dependency: libcom_err(x86-64) = 1.42.9-9.el7 for package: libss-1.42.9-9.el7.x86_64
--> Processing Dependency: libcom_err(x86-64) = 1.42.9-9.el7 for package: e2fsprogs-libs-1.42.9-9.el7.x86_64
--> Processing Dependency: libcom_err(x86-64) = 1.42.9-9.el7 for package: e2fsprogs-1.42.9-9.el7.x86_64
---> Package libcom_err.i686 0:1.42.9-10.el7 will be installed
---> Package libcom_err.x86_64 0:1.42.9-10.el7 will be an update
---> Package libidn.i686 0:1.28-4.el7 will be installed
---> Package libssh2.i686 0:1.4.3-10.el7_2.1 will be installed
---> Package nspr.i686 0:4.13.1-1.0.el7_3 will be installed
---> Package nss.x86_64 0:3.28.4-1.2.el7_3 will be updated
--> Processing Dependency: nss = 3.28.4-1.2.el7_3 for package: nss-sysinit-3.28.4-1.2.el7_3.x86_64
--> Processing Dependency: nss(x86-64) = 3.28.4-1.2.el7_3 for package: nss-tools-3.28.4-1.2.el7_3.x86_64
---> Package nss.i686 0:3.28.4-8.el7 will be installed
--> Processing Dependency: nss-softokn(x86-32) >= 3.28.3-4 for package: nss-3.28.4-8.el7.i686
--> Processing Dependency: nss-pem(x86-32) for package: nss-3.28.4-8.el7.i686
---> Package nss.x86_64 0:3.28.4-8.el7 will be an update
--> Processing Dependency: nss-pem(x86-64) for package: nss-3.28.4-8.el7.x86_64
---> Package nss-softokn-freebl.x86_64 0:3.16.2.3-14.4.el7 will be updated
---> Package nss-softokn-freebl.i686 0:3.28.3-6.el7 will be installed
---> Package nss-softokn-freebl.x86_64 0:3.28.3-6.el7 will be an update
---> Package nss-util.x86_64 0:3.28.4-1.0.el7_3 will be updated
---> Package nss-util.i686 0:3.28.4-3.el7 will be installed
---> Package nss-util.x86_64 0:3.28.4-3.el7 will be an update
---> Package openldap.x86_64 0:2.4.40-13.el7 will be updated
---> Package openldap.i686 0:2.4.44-5.el7 will be installed
--> Processing Dependency: libsasl2.so.3 for package: openldap-2.4.44-5.el7.i686
---> Package openldap.x86_64 0:2.4.44-5.el7 will be an update
---> Package xz-libs.i686 0:5.2.2-1.el7 will be installed
---> Package zlib.i686 0:1.2.7-17.el7 will be installed
--> Running transaction check
---> Package cyrus-sasl-lib.x86_64 0:2.1.26-20.el7_2 will be updated
--> Processing Dependency: cyrus-sasl-lib(x86-64) = 2.1.26-20.el7_2 for package: cyrus-sasl-2.1.26-20.el7_2.x86_64
--> Processing Dependency: cyrus-sasl-lib(x86-64) = 2.1.26-20.el7_2 for package: cyrus-sasl-md5-2.1.26-20.el7_2.x86_64
---> Package cyrus-sasl-lib.i686 0:2.1.26-21.el7 will be installed
--> Processing Dependency: libdb-5.3.so for package: cyrus-sasl-lib-2.1.26-21.el7.i686
---> Package cyrus-sasl-lib.x86_64 0:2.1.26-21.el7 will be an update
---> Package e2fsprogs.x86_64 0:1.42.9-9.el7 will be updated
---> Package e2fsprogs.x86_64 0:1.42.9-10.el7 will be an update
---> Package e2fsprogs-libs.x86_64 0:1.42.9-9.el7 will be updated
---> Package e2fsprogs-libs.x86_64 0:1.42.9-10.el7 will be an update
---> Package keyutils-libs.i686 0:1.5.8-3.el7 will be installed
---> Package libselinux.x86_64 0:2.5-6.el7 will be updated
--> Processing Dependency: libselinux(x86-64) = 2.5-6.el7 for package: libselinux-ruby-2.5-6.el7.x86_64
--> Processing Dependency: libselinux(x86-64) = 2.5-6.el7 for package: libselinux-utils-2.5-6.el7.x86_64
--> Processing Dependency: libselinux(x86-64) = 2.5-6.el7 for package: libselinux-python-2.5-6.el7.x86_64
---> Package libselinux.i686 0:2.5-11.el7 will be installed
--> Processing Dependency: libsepol(x86-32) >= 2.5-6 for package: libselinux-2.5-11.el7.i686
--> Processing Dependency: libpcre.so.1 for package: libselinux-2.5-11.el7.i686
--> Processing Dependency: libsepol.so.1 for package: libselinux-2.5-11.el7.i686
--> Processing Dependency: libsepol.so.1(LIBSEPOL_1.0) for package: libselinux-2.5-11.el7.i686
---> Package libselinux.x86_64 0:2.5-11.el7 will be an update
---> Package libss.x86_64 0:1.42.9-9.el7 will be updated
---> Package libss.x86_64 0:1.42.9-10.el7 will be an update
---> Package libverto.i686 0:0.2.5-4.el7 will be installed
---> Package nss-pem.i686 0:1.0.3-4.el7 will be installed
---> Package nss-pem.x86_64 0:1.0.3-4.el7 will be installed
---> Package nss-softokn.x86_64 0:3.16.2.3-14.4.el7 will be updated
---> Package nss-softokn.i686 0:3.28.3-6.el7 will be installed
--> Processing Dependency: libsqlite3.so.0 for package: nss-softokn-3.28.3-6.el7.i686
---> Package nss-softokn.x86_64 0:3.28.3-6.el7 will be an update
---> Package nss-sysinit.x86_64 0:3.28.4-1.2.el7_3 will be updated
---> Package nss-sysinit.x86_64 0:3.28.4-8.el7 will be an update
---> Package nss-tools.x86_64 0:3.28.4-1.2.el7_3 will be updated
---> Package nss-tools.x86_64 0:3.28.4-8.el7 will be an update
---> Package openssl-libs.x86_64 1:1.0.1e-60.el7_3.1 will be updated
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.1e-60.el7_3.1 for package: 1:openssl-1.0.1e-60.el7_3.1.x86_64
---> Package openssl-libs.i686 1:1.0.2k-8.el7 will be installed
---> Package openssl-libs.x86_64 1:1.0.2k-8.el7 will be an update
--> Running transaction check
---> Package cyrus-sasl.x86_64 0:2.1.26-20.el7_2 will be updated
---> Package cyrus-sasl.x86_64 0:2.1.26-21.el7 will be an update
---> Package cyrus-sasl-md5.x86_64 0:2.1.26-20.el7_2 will be updated
---> Package cyrus-sasl-md5.x86_64 0:2.1.26-21.el7 will be an update
---> Package libdb.x86_64 0:5.3.21-19.el7 will be updated
--> Processing Dependency: libdb(x86-64) = 5.3.21-19.el7 for package: libdb-utils-5.3.21-19.el7.x86_64
---> Package libdb.i686 0:5.3.21-20.el7 will be installed
---> Package libdb.x86_64 0:5.3.21-20.el7 will be an update
---> Package libselinux-python.x86_64 0:2.5-6.el7 will be updated
---> Package libselinux-python.x86_64 0:2.5-11.el7 will be an update
---> Package libselinux-ruby.x86_64 0:2.5-6.el7 will be updated
---> Package libselinux-ruby.x86_64 0:2.5-11.el7 will be an update
---> Package libselinux-utils.x86_64 0:2.5-6.el7 will be updated
---> Package libselinux-utils.x86_64 0:2.5-11.el7 will be an update
---> Package libsepol.i686 0:2.5-6.el7 will be installed
---> Package openssl.x86_64 1:1.0.1e-60.el7_3.1 will be updated
---> Package openssl.x86_64 1:1.0.2k-8.el7 will be an update
---> Package pcre.x86_64 0:8.32-15.el7_2.1 will be updated
---> Package pcre.i686 0:8.32-17.el7 will be installed
--> Processing Dependency: libgcc_s.so.1 for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libstdc++.so.6 for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.9) for package: pcre-8.32-17.el7.i686
---> Package pcre.x86_64 0:8.32-17.el7 will be an update
---> Package sqlite.i686 0:3.7.17-8.el7 will be installed
--> Processing Dependency: libncurses.so.5 for package: sqlite-3.7.17-8.el7.i686
--> Processing Dependency: libreadline.so.6 for package: sqlite-3.7.17-8.el7.i686
--> Processing Dependency: libtinfo.so.5 for package: sqlite-3.7.17-8.el7.i686
--> Running transaction check
---> Package libdb-utils.x86_64 0:5.3.21-19.el7 will be updated
---> Package libdb-utils.x86_64 0:5.3.21-20.el7 will be an update
---> Package libgcc.x86_64 0:4.8.5-11.el7 will be updated
---> Package libgcc.i686 0:4.8.5-16.el7 will be installed
---> Package libgcc.x86_64 0:4.8.5-16.el7 will be an update
---> Package libstdc++.x86_64 0:4.8.5-11.el7 will be updated
--> Processing Dependency: libstdc++ = 4.8.5-11.el7 for package: gcc-c++-4.8.5-11.el7.x86_64
--> Processing Dependency: libstdc++(x86-64) = 4.8.5-11.el7 for package: libstdc++-devel-4.8.5-11.el7.x86_64
---> Package libstdc++.i686 0:4.8.5-16.el7 will be installed
---> Package libstdc++.x86_64 0:4.8.5-16.el7 will be an update
---> Package ncurses-libs.i686 0:5.9-13.20130511.el7 will be installed
---> Package readline.x86_64 0:6.2-9.el7 will be updated
---> Package readline.i686 0:6.2-10.el7 will be installed
---> Package readline.x86_64 0:6.2-10.el7 will be an update
--> Running transaction check
---> Package gcc-c++.x86_64 0:4.8.5-11.el7 will be updated
---> Package gcc-c++.x86_64 0:4.8.5-16.el7 will be an update
--> Processing Dependency: gcc = 4.8.5-16.el7 for package: gcc-c++-4.8.5-16.el7.x86_64
---> Package libstdc++-devel.x86_64 0:4.8.5-11.el7 will be updated
---> Package libstdc++-devel.x86_64 0:4.8.5-16.el7 will be an update
--> Running transaction check
---> Package gcc.x86_64 0:4.8.5-11.el7 will be updated
---> Package gcc.x86_64 0:4.8.5-16.el7 will be an update
--> Processing Dependency: cpp = 4.8.5-16.el7 for package: gcc-4.8.5-16.el7.x86_64
--> Processing Dependency: libgomp = 4.8.5-16.el7 for package: gcc-4.8.5-16.el7.x86_64
--> Running transaction check
---> Package cpp.x86_64 0:4.8.5-11.el7 will be updated
---> Package cpp.x86_64 0:4.8.5-16.el7 will be an update
---> Package libgomp.x86_64 0:4.8.5-11.el7 will be updated
---> Package libgomp.x86_64 0:4.8.5-16.el7 will be an update
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for libwsman1 which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of libwsman1 of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude libwsman1.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of libwsman1 installed, but
            yum can only see an upgrade for one of those architectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of libwsman1 installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: libwsman1-2.3.6-13.el7.i686 != libwsman1-2.3.6-14.el7.x86_64
Comment 9 errata-xmlrpc 2017-08-01 20:49:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2409

Note You need to log in before you can comment on or make changes to this bug.