Bug 1460221 - [UPDATES] Dependecies for openwsman-python when updating RHOS-9 to RHEL-7.4 [openstack-8]
[UPDATES] Dependecies for openwsman-python when updating RHOS-9 to RHEL-7.4 [...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openwsman (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity high
: async
: 8.0 (Liberty)
Assigned To: Mike Burns
nlevinki
: Triaged
Depends On: 1460215
Blocks: 1470581
  Show dependency treegraph
 
Reported: 2017-06-09 08:00 EDT by Mike Burns
Modified: 2017-08-01 20:49 EDT (History)
14 users (show)

See Also:
Fixed In Version: openwsman-2.3.6-14.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1460215
: 1470581 (view as bug list)
Environment:
Last Closed: 2017-08-01 20:49:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2409 normal SHIPPED_LIVE Red Hat OpenStack director update for RHEL 7.4 2017-08-01 21:00:40 EDT

  None (edit)
Description Mike Burns 2017-06-09 08:00:36 EDT
This will also impact OSP 8

+++ This bug was initially created as a clone of Bug #1460215 +++

Description of problem:
-----------------------
Attempt to update RHOS-9 running on RHEL-7.3 fails:
...
--> Processing Dependency: libwsman1 = 2.3.6-13.el7 for package: openwsman-python-2.3.6-13.el7.x86_64
--> Finished Dependency Resolution
Error: Package: openwsman-python-2.3.6-13.el7.x86_64 (@rhelosp-9.0-director-puddle)
           Requires: libwsman1 = 2.3.6-13.el7
           Removing: libwsman1-2.3.6-13.el7.x86_64 (@rhelosp-rhel-7.3-server)
               libwsman1 = 2.3.6-13.el7
           Updated By: libwsman1-2.3.6-14.el7.x86_64 (rhelosp-rhel-7.4-server)
               libwsman1 = 2.3.6-14.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Command '['sudo', 'yum', 'update', '-y']' returned non-zero exit status 1

[root@undercloud-0 ~]# yum info libwsman1.x86_64
Loaded plugins: search-disabled-repos
Installed Packages
Name        : libwsman1
Arch        : x86_64
Version     : 2.3.6
Release     : 13.el7
Size        : 314 k
Repo        : installed
From repo   : rhelosp-rhel-7.3-server
Summary     : Open source Implementation of WS-Management
URL         : http://www.openwsman.org/
License     : BSD
Description : Openwsman library for packages dependent on openwsman

Available Packages
Name        : libwsman1
Arch        : x86_64
Version     : 2.3.6
Release     : 14.el7
Size        : 125 k
Repo        : rhelosp-rhel-7.4-server/x86_64
Summary     : Open source Implementation of WS-Management
URL         : http://www.openwsman.org/
License     : BSD
Description : Openwsman library for packages dependent on openwsman



Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openwsman-python-2.3.6-13.el7.x86_64
openstack-tripleo-heat-templates-liberty-2.0.0-49.el7ost.noarch
openstack-tripleo-heat-templates-2.0.0-49.el7ost.noarch

Steps to Reproduce:
-------------------
1. Deploy RHOS-9 (director 2017-05-05.2, build 2017-05-05.1)
2. Setup latest repos (director 2017-06-01.1, build 2017-05-31.1, RHEL-7.4 repo)
3. Try update uc
Comment 7 errata-xmlrpc 2017-08-01 20:49:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2409

Note You need to log in before you can comment on or make changes to this bug.