Bug 1460256 - pitivi is installed but fails to run
pitivi is installed but fails to run
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pitivi (Show other bugs)
26
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-09 09:49 EDT by Harish Pillay
Modified: 2017-06-14 23:12 EDT (History)
5 users (show)

See Also:
Fixed In Version: pitivi-0.98-7.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-14 23:01:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harish Pillay 2017-06-09 09:49:57 EDT
Description of problem:
On a Fedora 26 (alpha) system, pitivi is installed successfully, but fails to run when invoked. It says: 
"ERROR - The following hard dependencies are unmet:
==================================================
- gstgtk not found on the system"


Version-Release number of selected component (if applicable):
pitivi-0.98-6.fc26.x86_64

How reproducible:
Install pitivi as per usual mode (dnf install pitivi) and it succeeds. Running it causes it to fail throwing out the exception of not being able to have gstgtk in the system.

Steps to Reproduce:
1. Fresh Fedora 26 alpha
2. Install pitivi
3. start pitivi

Actual results:
the error message that sayt that gstgtk is not found in the system.

Expected results:
pitivi should run in the GUI mode

Additional info:
This behaviour is seen on systems that were upgraded from Fedora 25 which had pitivi running fine.
Comment 1 Fedora Update System 2017-06-09 11:16:49 EDT
pitivi-0.98-7.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1e49098bd5
Comment 2 Harish Pillay 2017-06-09 13:13:49 EDT
[harish@gillman ~]$ rpm -qa pitivi
pitivi-0.98-6.fc26.x86_64

forgot to include the version. yes, looks like the update is what i would need. i shall wait for it to be available before closing this.

thanks.
Comment 3 Gwyn Ciesla 2017-06-09 13:15:45 EDT
Excellent!

It will be automatically closed when the update goes to stable.
Comment 4 Fedora Update System 2017-06-12 00:38:43 EDT
pitivi-0.98-7.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1e49098bd5
Comment 5 Harish Pillay 2017-06-12 02:08:24 EDT
Thanks. I will test this out.
Comment 6 Harish Pillay 2017-06-14 08:57:49 EDT
It works now.

There is a (pitivi:2572): Gtk-WARNING **: Allocating size to GtkScrollbar 0x55f282a7cee0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

which I will file separately.

Thanks.
Comment 7 Fedora Update System 2017-06-14 23:01:51 EDT
pitivi-0.98-7.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Harish Pillay 2017-06-14 23:12:52 EDT
thanks.

Note You need to log in before you can comment on or make changes to this bug.