Bug 1460345 - Computer performs reboot instead of shutdown unless xHCI support is turned off in BIOS
Computer performs reboot instead of shutdown unless xHCI support is turned of...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
26
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-09 14:39 EDT by Jerry
Modified: 2018-03-07 10:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-07 10:11:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry 2017-06-09 14:39:50 EDT
Description of problem:

The computer seems to power off but then reboots after a shutdown command.  If xHCI support is disabled in BIOS, the machine successfully shuts down.

Version-Release number of selected component (if applicable):

4.11.3-302.fc26.x86_64

How reproducible:

Very.

Additional info:

The motherboard is a P8Z77-V Pro.

I tried to blacklist the xhci_hcd module but it is built in to the kernel.  I also tried as a kernel parameter but this didn't work either (I suppose for the same reason).

I am happy to provide logs or further debugging if needed.  I know a few things about linux but I appreciate explicit instructions if possible.
Comment 1 Jerry 2017-06-13 10:15:27 EDT
I found a post on a forum about disabling Wake on LAN in the BIOS, which in my case is Power on by PCI.  I had that switched on in the BIOS so I could send a magic packet to wake my machine.  I switched that off and shutdown works now.

This is still not good for me as I'd like to be able to wake my machine from the network.
Comment 2 Jerry 2017-06-13 14:33:54 EDT
As usual, after asking for help / posting a bug, I figured out a fix after much internet searching.

Appending

xhci_hcd.quirks=262144

to GRUB_CMDLINE_LINUX in /etc/default/grub to account for the XHCI_SPURIOUS_WAKEUP flag (for those watching) took care of the bogus wakeups after a shutdown.

I made sure that I could still do a wake on LAN following the guide here:

https://nullr0ute.com/2014/02/simple-wol-with-rhel-and-fedora/

In my case, I had to enter ethtool -s eno1 wol g -- he forgot to specify a device in his guide.
Comment 3 Laura Abbott 2018-02-27 23:00:18 EST
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale. The kernel moves very fast so bugs may get fixed as part of a kernel update. Due to this, we are doing a mass bug update across all of the Fedora 26 kernel bugs.
 
Fedora 26 has now been rebased to 4.15.4-200.fc26.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 27, and are still experiencing this issue, please change the version to Fedora 27.
 
If you experience different issues, please open a new bug report for those.
Comment 4 Jerry 2018-03-06 21:38:25 EST
I have since removed the XHCI_SPURIOUS_WAKEUP flag.  I am not experiencing bogus wakeups after shutdown anymore in Fedora 27.
Comment 5 Laura Abbott 2018-03-07 10:11:31 EST
Thanks for letting us know

Note You need to log in before you can comment on or make changes to this bug.