Bug 146035 - clvmd cannot activate pool volumes with static minor numbers
clvmd cannot activate pool volumes with static minor numbers
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-24 15:51 EST by Derek Anderson
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2005-192
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-11 14:50:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Anderson 2005-01-24 15:51:58 EST
Description of problem:
Used a node running GFS 6.0.2 to create a pool with a static minor
number of 1.  Such as:

poolname POOLIO1
minor 1
subpools 1
subpool 0 512 1 gfs_data
pooldevice 0 0 /dev/sda1

Now on the quorate 6.1 cluster ran clvmd on all, ran vgscan on all,
then vgchange -ay.  The volume does not activate because the minor
number one is already in use (on my cluster the root partition is also
an LVM2 volume so that got minor 1).

It looks like pools configured with dynamic minor numbers are OK.  But
there are bound to be existing customers configured with static minors
and they may or may not have a good reason for having done so (NFS
failover?).

Version-Release number of selected component (if applicable):
lvm> version
  LVM version:     2.01.00 (2005-01-17)
  Library version: 1.01.00-ioctl (2005-01-17)
  Driver version:  4.1.0


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alasdair Kergon 2005-01-27 11:25:29 EST
For now, let's just add a constant to the minor number when mapping
the pool metadata into lvm2 metadata, to move it outside the range
that normally gets used by lvm2.

The long-term fix will be to port multiple-major-number support to 2.6
Comment 2 Alasdair Kergon 2005-02-11 13:23:50 EST
I added a constant offset in the last release - please test it.
Comment 3 Derek Anderson 2005-02-11 14:50:31 EST
Tested a couple of pool devices with static minors 1 and 60.  Here's
how they look:

  --- Logical volume ---
  LV Name                /dev/POOLIO1/POOLIO1
  VG Name                POOLIO1
  LV UUID                POOL00-0000-000W-FnFk-0DaB-LF00-000000
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                135.67 GB
  Current LE             17781920
  Segments               1
  Allocation             normal
  Read ahead sectors     0
  Persistent major       121
  Persistent minor       65537
  Block device           253:65537

  --- Logical volume ---
  LV Name                /dev/POOLIO2/POOLIO2
  VG Name                POOLIO2
  LV UUID                POOL00-0000-000U-wXvP-2DaB-LF00-000000
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                135.67 GB
  Current LE             17781920
  Segments               1
  Allocation             normal
  Read ahead sectors     0
  Persistent major       121
  Persistent minor       65596
  Block device           253:65596

Verified in version lvm2-2.01.04-1.0.RHEL4.
Comment 4 Tim Powers 2005-06-09 08:29:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-192.html

Note You need to log in before you can comment on or make changes to this bug.