Bug 146044 - IndexError: list index out of range
IndexError: list index out of range
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-24 16:43 EST by Graham Leggett
Modified: 2013-02-26 19:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 12:06:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2005-01-24 16:43:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040925

Description of problem:
While trying to upgrade a kernel, up2date will sometimes bomb out with
this error:

[root@samantha root]# up2date -u --force kernel kernel-unsupported
https://www.rhns.redhat.com/XMLRPC
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1174, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 772, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1066, in batchRun
    batch.run()
  File "up2dateBatch.py", line 62, in run
  File "up2dateBatch.py", line 97, in __findPackagesToUpdate
  File "packageList.py", line 157, in addGlobs
  File "rhnPackageInfo.py", line 232, in getAvailablePackageList
  File "rhnPackageInfo.py", line 150, in availablePackageList
  File "repoDirector.py", line 64, in initRepoDirector
  File "/usr/share/rhn/up2date_client/repoBackends/up2dateRepo.py",
line 345, in register
    up2dateRepo = Up2dateRepo()
  File "/usr/share/rhn/up2date_client/repoBackends/up2dateRepo.py",
line 304, in __init__
    serverSettings)
  File "/usr/share/rhn/up2date_client/repoBackends/up2dateRepo.py",
line 247, in getGETServer
    server= rpcServer.RetryGETServer(serverSettings.serverList.server(),
  File "rpcServer.py", line 103, in server
IndexError: list index out of range


Version-Release number of selected component (if applicable):
up2date-4.2.38-1

How reproducible:
Sometimes

Steps to Reproduce:
xxx

Additional info:
Comment 1 Vlady Zlatkin 2007-05-23 09:50:45 EDT
I also see the same error in up2date-4.4.67-3 at a slightly different location

Traceback (most recent call last):
  File "/usr/sbin/rhnreg_ks", line 357, in ?
    
  File "/usr/sbin/rhnreg_ks", line 331, in main
    if serialnumber:
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 391, in sendSerialNumber
    s = rpcServer.getServer()
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 186, in getServer
    
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 104, in server
    return self.serverurl
IndexError: list index out of range

It happens when I run up2date on any package and is the result of server load.  

/etc/sysconfig/rhn/up2date just has one server listed in *erverURL=
Comment 2 Mike McCune 2007-05-23 23:11:29 EDT
vlad,
this something you are seeing at GS?  this may be difficult to reproduce since
its load related.
Comment 3 Pradeep Kilambi 2007-05-24 10:10:50 EDT
tried a couple of ways against our hosted/sat servers but as Mike mentioned its
kinda hard to reproduce this load issue. Do you still have the box you
reproduced this on? and could I play on it a little bit?

Also this probably should be aligned to 4.6 and not 500.
Comment 4 RHEL Product and Program Management 2007-05-24 10:24:53 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Suzanne Yeghiayan 2007-09-17 16:09:08 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 6 RHEL Product and Program Management 2007-11-28 23:27:16 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 RHEL Product and Program Management 2008-01-08 22:35:55 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Cameron Meadors 2008-01-29 08:51:26 EST
Could you please elaborate of the server load required to reproduce this bug? 
What exactly is the trigger for the bug?  Is it simply the server not
responding?  or is it a failure to repond to a specific request?
Comment 10 Pradeep Kilambi 2008-02-18 11:28:12 EST
From what i recall the server wasn't responding for the getRetryServer call.. so
looks like the server load itself.. unfortunately I was not able to reproduce
this issue.
Comment 14 RHEL Product and Program Management 2008-02-28 12:06:51 EST
Quality Engineering Management has reviewed and declined this request.  You may
appeal this decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.