Bug 146047 - clvmd to cman connection errors on start-up when using gulm
clvmd to cman connection errors on start-up when using gulm
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: lvm2-cluster (Show other bugs)
4
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Christine Caulfield
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-24 17:32 EST by Corey Marthaler
Modified: 2010-01-11 23:02 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-14 18:17:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2005-01-24 17:32:44 EST
Description of problem:
When I start up clvm for use with gulm, I see the follow cman errors:

Jan 24 16:24:00 morph-01 clvmd: Can't open cman cluster manager
socket: Address family not supported by protocol
Jan 24 16:24:00 morph-01 lvm[4110]: Unable to connect to remote node:
Connection refused

Is this just clvmd's way of deciding which lock manager to connect to?

Customers tend to not like seeing stuff like this in SYSLOGs.


Version-Release number of selected component (if applicable):
[root@morph-01 root]# clvmd -V
Cluster LVM daemon version: 2.01.02 (2005-01-21)
Protocol version:           0.2.1


How reproducible:
Always
Comment 1 Christine Caulfield 2005-01-26 04:32:01 EST
Removed the probe error message. it made sense with the
single-function clvmd but not now.

Checking in daemons/clvmd/clvmd-cman.c;
/cvs/lvm2/LVM2/daemons/clvmd/clvmd-cman.c,v  <--  clvmd-cman.c
new revision: 1.10; previous revision: 1.9
done
Comment 2 Corey Marthaler 2005-02-01 14:41:15 EST
It's still in the latest build:

Feb  1 13:33:48 morph-01 clvmd: Cluster LVM daemon started - connected
to GULM
Feb  1 13:33:48 morph-01 sshd(pam_unix)[4366]: session closed for user
root
Feb  1 13:33:48 morph-01 lvm[4376]: Unable to connect to remote node:
Connection refused
Feb  1 13:33:48 morph-01 last message repeated 3 times

[root@morph-01 root]# rpm -qa | grep lvm
lvm2-2.01.03-1.0.RHEL4
lvm2-cluster-2.01.03-1.0.RHEL4
[root@morph-01 root]# clvmd -V
Cluster LVM daemon version: 2.01.03 (2005-02-01)
Protocol version:           0.2.1

Comment 3 Corey Marthaler 2005-02-01 16:25:37 EST
The "clvmd: Can't open cman cluster manager socket: Address family not
supported by protocol" is now gone but the "lvm[3754]: Unable to
connect to remote node: Connection refused" messages still show up
Comment 4 Christine Caulfield 2005-02-02 03:33:30 EST
That's because it's nothing to do with cman - that's the clvmd trying
to contact a (non-running) clvmd on another GULM node.
Comment 5 Christine Caulfield 2005-02-02 04:18:25 EST
OK, that one's gone too.

Checking in daemons/clvmd/tcp-comms.c;
/cvs/lvm2/LVM2/daemons/clvmd/tcp-comms.c,v  <--  tcp-comms.c
new revision: 1.5; previous revision: 1.4
done
Comment 6 Corey Marthaler 2005-02-14 18:17:51 EST
fix verified.

Note You need to log in before you can comment on or make changes to this bug.