Bug 1460478 - USB iso Installation not able to proceed during anaconda installer with Error setting up base repository on UEFI mode
USB iso Installation not able to proceed during anaconda installer with Erro...
Status: CLOSED CURRENTRELEASE
Product: ovirt-node
Classification: oVirt
Component: Installation & Update (Show other bugs)
4.1
x86_64 Linux
unspecified Severity medium (vote)
: ovirt-4.1.4
: ---
Assigned To: Yuval Turgeman
cshao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-10 21:01 EDT by kamarasu
Modified: 2017-07-28 10:14 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-28 10:14:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
cshao: testing_ack+


Attachments (Terms of Use)
uefi1 (467.82 KB, image/jpeg)
2017-06-29 04:44 EDT, cshao
no flags Details
uefi2 (357.78 KB, image/jpeg)
2017-06-29 04:58 EDT, cshao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78825 master MERGED scripts: modify grub.cfg in efiboot image 2017-06-29 09:54 EDT
oVirt gerrit 78827 ovirt-4.1 MERGED scripts: modify grub.cfg in efiboot image 2017-06-29 09:55 EDT
oVirt gerrit 78828 ovirt-4.1-pre MERGED scripts: modify grub.cfg in efiboot image 2017-06-29 09:55 EDT
oVirt gerrit 78829 ovirt-4.1-snapshot MERGED scripts: modify grub.cfg in efiboot image 2017-06-29 09:55 EDT

  None (edit)
Description kamarasu 2017-06-10 21:01:25 EDT
Description of problem:

Ovirt node Installation not able to proceed during anaconda installer with Error setting up base repository on UEFI mode

Version-Release number of selected component (if applicable):
4.1

How reproducible:

always

Steps to Reproduce:
1. Download ovirt node iso
http://resources.ovirt.org/pub/ovirt-4.1/iso/ovirt-node-ng-installer/ovirt-node-ng-installer-ovirt-4.1-2017052309.iso

2. Boot into UEFI enabled system using iso burned onto USB device

Actual results:

at the Installation summary the installation source selection fails with Error setting up base repository

Expected results:

installation source selection should succeeds automatically

Additional info:
kamarasu@aol.in
Comment 1 cshao 2017-06-12 23:17:08 EDT
The issue was gone with below the latest version. Please have a try.

http://resources.ovirt.org/pub/ovirt-4.1-snapshot/iso/ovirt-node-ng-installer-ovirt/ovirt-node-ng-installer-ovirt-4.1-pre-2017061204.iso
Comment 3 kamarasu 2017-06-17 08:46:55 EDT
Hi cshao

I'm sorry I have made mistake while testing before, none of them works the issue still persists. Actually I did not set the server bios mode to UEFI and thus it worked on booting into Legacy BIOS mode.

I have installed same iso on the server through ILO virtual media in UEFI mode everything owrked fine, something fizzy going on while using USB device as source for installation media.
Comment 4 Yuval Turgeman 2017-06-18 02:15:06 EDT
(In reply to kamarasu from comment #3)
> Hi cshao
> 
> I'm sorry I have made mistake while testing before, none of them works the
> issue still persists. Actually I did not set the server bios mode to UEFI
> and thus it worked on booting into Legacy BIOS mode.
> 
> I have installed same iso on the server through ILO virtual media in UEFI
> mode everything owrked fine, something fizzy going on while using USB device
> as source for installation media.

Hi, how did you copy the iso to the usb device ?
Comment 5 kamarasu 2017-06-18 09:12:56 EDT
I did copied iso using dd and have also used livecd tools, all methods behaves similar issues.
Comment 6 Yuval Turgeman 2017-06-27 04:09:06 EDT
I tried with 

dd if=ovirt-node-ng-installer-ovirt-4.1-pre-2017062209.iso of=/dev/sdb bs=4MB

and could not reproduce this, can you please try with the latest iso and paste the command you used for transferring the iso to the usb ?
Comment 7 cshao 2017-06-29 03:28:55 EDT
(In reply to kamarasu from comment #5)
> I did copied iso using dd and have also used livecd tools, all methods
> behaves similar issues.

Does it work on BIOS mode?
Could you upload screen-shot with the issue?
Comment 8 cshao 2017-06-29 04:41:17 EDT
I can reproduce it now.But there are some different with the original issue.
During anaconda installation, you can create a new repository and fill a valid url to download package metadata, then the installation source selection should succeeds automatically.

Test steps:
1. Download ISO
2. dd if=ovirt-node-ng-installer-ovirt-4.1-2017061204.iso of=/dev/sdb bs=4M
3. Boot into UEFI enabled system using iso burned onto USB device
4. Enter - Installation Summary > Software > Create new repository >  fill a valid url to download package metadata

Test result:
The installation can't continue, it always show "Downloading package metadata..." and lasts about 20 minutes. I am not sure whether it is related with my local url, but you can have a try with above steps first.
Comment 9 cshao 2017-06-29 04:44 EDT
Created attachment 1292814 [details]
uefi1
Comment 10 cshao 2017-06-29 04:58 EDT
Created attachment 1292818 [details]
uefi2
Comment 11 cshao 2017-07-11 00:50:13 EDT
Yuval,

Could you help to fill the "fixed in version" that QE can verify this bug according the indication.

NOTE:
In the latest ovirt-node-ng-installer-ovirt-4.1-pre-2017071004.iso, it still using RHEL 73 package but not RHEL 7.4.
Comment 12 Huijuan Zhao 2017-07-11 23:46:09 EDT
Test version:
ovirt-node-ng-installer-ovirt-4.1-2017070915.iso
imgbased-0.9.31-1.el7.centos.noarch


Test steps:
1. Download ISO
2. Make USB install disk:
   # dd if=ovirt-node-ng-installer-ovirt-4.1-2017070915.iso of=/dev/sdb bs=4M
3. Boot into UEFI enabled system using iso burned onto USB device
4. Install ovirt-node-ng via anaconda
5. Enter host, do some checks


Test results:
1. After step 4, install ovirt-node-ng successful.

2. After step 5, 
# imgbase w
2017-07-12 03:28:59,027 [INFO] You are on ovirt-node-ng-4.1.3-0.20170709.0+1

# imgbase layout
ovirt-node-ng-4.1.3-0.20170709.0
 +- ovirt-node-ng-4.1.3-0.20170709.0+1

# rpm -qa | grep imgbase
imgbased-0.9.31-1.el7.centos.noarch


So this bug is fixed in ovirt-node-ng-installer-ovirt-4.1-2017070915.iso, change the status to VERIFIED.
Comment 13 Yuval Turgeman 2017-07-12 06:19:07 EDT
Thanks, it's probably not relevant after the verify, but all versions after 20170629 should be fixed.

Note You need to log in before you can comment on or make changes to this bug.