Bug 146050 - linux-iscsi per-lun queueing limits are small at 12 IOs per lun
linux-iscsi per-lun queueing limits are small at 12 IOs per lun
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Christie
Brock Organ
RHEL3U7NAK
: FutureFeature
Depends On:
Blocks: 170417
  Show dependency treegraph
 
Reported: 2005-01-24 17:40 EST by Dave Wysochanski
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:08:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Wysochanski 2005-01-24 17:40:06 EST
Description of problem:
The file iscsi-limits.h specifies a low number for ISCSI_CMDS_PER_LUN
(currently 12). This will impact performance when IOs take longer to
complete on a target (i.e. consider the case of random reads), and the
initiator would benefit from increasing this beyond 12.



Version-Release number of selected component (if applicable):
3.6.2-4


How reproducible:
N/A


Steps to Reproduce:
N/A

  
Actual results:
Reduced performance with higher latency IO workloads (e.g. random IO)


Expected results:
Better performance with higher latency IO workloads (e.g. random IO)



Additional info:
Fix has already been checked into sourceforge 3-6 branch to increase
IOs per LUN from 12 to 32.

Since we're seeing lockups with RHEL3, U4 kernel (see bugzilla
145818), we probably need to tread more carefully here, as this has
the potential to change the memory consumption characteristics of the
iscsi driver, and potentially lead to more problems.  Note that this
is not a request to increase the can_queue value, so it might not be a
big deal.  However, it needs to be fully tested and not just put in
there without much testing.
Comment 1 Tom Coughlan 2005-01-24 21:41:23 EST
Hi Dave, this request is on my list for U5. I have already started
testing it, and will continue, with an eye on the outcome of BZ 145818.
Comment 2 Tom Coughlan 2005-03-08 10:45:39 EST
I decided not to make this change because it could make the problem in BZ 145818
worse. Once we have (at least a partial) workaround for BZ 145818, then we will
increase the queue depth.
Comment 3 Dave Wysochanski 2005-09-01 14:53:54 EDT
FYI - just had another internal (netapp) customer asking about this.
Comment 7 RHEL Product and Program Management 2007-10-19 15:08:55 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.