Bug 1460590 - [UI] - UI Exception on network edit after failure to attach non-mgmt network with default route role to host
[UI] - UI Exception on network edit after failure to attach non-mgmt network ...
Status: CLOSED WORKSFORME
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
4.2.0
x86_64 Linux
medium Severity low (vote)
: ovirt-4.2.0
: ---
Assigned To: Martin Mucha
Meni Yakove
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 02:32 EDT by Michael Burman
Modified: 2017-10-09 17:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-09 17:55:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)
ui log (23.90 KB, application/x-gzip)
2017-06-12 02:32 EDT, Michael Burman
no flags Details

  None (edit)
Description Michael Burman 2017-06-12 02:32:52 EDT
Created attachment 1286931 [details]
ui log

Description of problem:
[UI] - UI Exception on network edit after failure to attach non-mgmt network with default route role to host.

When trying to attach a non-mgmt network with default route role to host, we failing cause of this bug - bz 1443292 , after this failure if trying to edit the network we got an ui exception.

2017-06-12 09:28:08,630+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-9) [] Permutation name: F10C70662BE9B4BE8EAA399EEC7A0E0B
2017-06-12 09:28:08,631+03 ERROR [org.ovirt.engine.ui.frontend.server.gwt.OvirtRemoteLoggingService] (default task-9) [] Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) : Cannot read property 'n' of undefined
        at java.lang.Throwable.Throwable(Throwable.java:70) [rt.jar:1.8.0_131]
        at java.lang.RuntimeException.RuntimeException(RuntimeException.java:32) [rt.jar:1.8.0_131]
        at com.google.web.bindery.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:64) [gwt-servlet.jar:]
        at com.google.gwt.event.shared.UmbrellaException.UmbrellaException(UmbrellaException.java:25) [gwt-servlet.jar:]

Version-Release number of selected component (if applicable):
4.2.0-0.0.master.20170611165620.git3c74d3b.el7.centos

How reproducible:
100

Steps to Reproduce:
1. Set non-mgmt network with default route role
2. Try to attach the network to host(set dhcp bootproto)
3. Try to edit network

Actual results:
2. Failed cause of bug bz 1443292
3. UI exception on edit network

Expected results:
No exception on edit network, even if the previous operation has failed.
Comment 1 Martin Mucha 2017-07-03 06:11:34 EDT
unable to reproduce.

ad 3: how do you edit network? Do you edit logical network (it either works or cancels operation, with explanation, that logical network is used) or do you actually edit network attachment? Edit of network attachment does not show any  UI exception and works.

Can you provide actual&specific steps to reproduce with actual&specific UI exception, which is produced?
Comment 2 Michael Burman 2017-07-03 07:25:43 EDT
(In reply to Martin Mucha from comment #1)
> unable to reproduce.
> 
> ad 3: how do you edit network? Do you edit logical network (it either works
> or cancels operation, with explanation, that logical network is used) or do
> you actually edit network attachment? Edit of network attachment does not
> show any  UI exception and works.
> 
> Can you provide actual&specific steps to reproduce with actual&specific UI
> exception, which is produced?

I meant to edit the network attachment.
Any how can't reproduce on latest master - 4.2.0-0.0.master.20170702100738.git46a9f67.el7.centos
Comment 3 Martin Mucha 2017-07-03 07:29:40 EDT
neither was I. I'd suggest to try to reproduce once patch:
https://gerrit.ovirt.org/#/c/78856/
is in. After this one, most problem should be gone and there's some probability that this one will be as well.
Comment 4 Dan Kenigsberg 2017-10-09 17:55:56 EDT
please reopen if ever reproduced.

Note You need to log in before you can comment on or make changes to this bug.