Bug 1460653 - "ODEBUG: 40 of 40 active objects replaced" shows when first logging in realtime guest with kernel-rt-debug
"ODEBUG: 40 of 40 active objects replaced" shows when first logging in realti...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: abrt (Show other bugs)
7.4
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: abrt
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 06:39 EDT by Pei Zhang
Modified: 2017-06-13 21:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-13 20:48:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pei Zhang 2017-06-12 06:39:47 EDT
Description of problem:
Install kernel-rt-debug in both host and guest. When first logging in rt guest by #ssh, 'ODEBUG: 40 of 40 active objects replaced' will be reported by abrt by guest. This problem only shows when first logging in guest, next several log in works well. 

Version-Release number of selected component (if applicable):
3.10.0-679.rt56.602.el7.x86_64.debug(in both host&guest)
qemu-kvm-rhev-2.9.0-7.el7.x86_64
libvirt-3.2.0-6.el7.x86_64
tuned-2.8.0-4.el7.noarch

How reproducible:
100%

Steps to Reproduce:

1. Boot rt host with kernel-rt-debug
2. Boot rt guest with kernel-rt-debug
3. Log in rt guest by #ssh, "ODEBUG: 40 of 40 active objects replaced" shows in terminal.

Actual results:
# ssh 10.73.75.76
root@10.73.75.76's password: 
Last login: Thu Jun  8 10:35:07 2017 from 10.66.60.114
ABRT has detected 1 problem(s). For more info run: abrt-cli list --since 1496889307

# abrt-cli list --since 1496889307
id 1eef41877a6c320527c5ff00022df70b7eff5338
reason:         ODEBUG: 40 of 40 active objects replaced
time:           Thu 08 Jun 2017 10:47:15 AM CST
cmdline:        BOOT_IMAGE=/vmlinuz-3.10.0-679.rt56.602.el7.x86_64.debug root=/dev/mapper/rhel_bootp--73--75--76-root ro console=tty0 console=ttyS0,115200n8 biosdevname=0 crashkernel=auto rd.lvm.lv=rhel_bootp-73-75-76/root rd.lvm.lv=rhel_bootp-73-75-76/swap rhgb quiet default_hugepagesz=1G LANG=en_US.UTF-8 isolcpus=1,2,3,4,5,6,7,8 intel_pstate=disable nosoftlockup skew_tick=1 nohz=on nohz_full=1,2,3,4,5,6,7,8 rcu_nocbs=1,2,3,4,5,6,7,8
package:        kernel
uid:            0 (root)
Directory:      /var/spool/abrt/oops-2017-06-08-10:47:15-933-0
Run 'abrt-cli report /var/spool/abrt/oops-2017-06-08-10:47:15-933-0' for creating a case in Red Hat Customer Portal


Expected results:
Should no problem warning shows.


Additional info:
Comment 1 Luiz Capitulino 2017-06-12 09:03:01 EDT
So, "ODEBUG: 40 of 40 active objects replaced" is all that's printed? Is this just an abrt debug message?
Comment 2 Luis Claudio R. Goncalves 2017-06-12 09:39:08 EDT
This message is just a _debug_ notification to tell you that the statically allocated objects were successfully converted into dynamic ones. This is not even a warning, just a debug note. You see this message because IIRC the debug kernels has the console on a very verbose mode by default.


From lib/debugobjects.c:


/*
 * Convert the statically allocated objects to dynamic ones:
 */
static int __init debug_objects_replace_static_objects(void)

   ...

   printk(KERN_DEBUG "ODEBUG: %d of %d active objects replaced\n", cnt,
               obj_pool_used);


If this message is all you see, this ticket can be safely closed as NOTABUG.
Comment 3 Pei Zhang 2017-06-13 20:48:49 EDT
(In reply to Luiz Capitulino from comment #1)
> So, "ODEBUG: 40 of 40 active objects replaced" is all that's printed? Is
> this just an abrt debug message?

Yes, it's the only message printed.

(In reply to Luis Claudio R. Goncalves from comment #2)
> This message is just a _debug_ notification to tell you that the statically
> allocated objects were successfully converted into dynamic ones. This is not
> even a warning, just a debug note. You see this message because IIRC the
> debug kernels has the console on a very verbose mode by default.
> 
> 
> From lib/debugobjects.c:
> 
> 
> /*
>  * Convert the statically allocated objects to dynamic ones:
>  */
> static int __init debug_objects_replace_static_objects(void)
> 
>    ...
> 
>    printk(KERN_DEBUG "ODEBUG: %d of %d active objects replaced\n", cnt,
>                obj_pool_used);
> 
> 
> If this message is all you see, this ticket can be safely closed as NOTABUG.

Get it. Thanks. Close this bug as 'NOTABUG'.



Thanks,
Pei

Note You need to log in before you can comment on or make changes to this bug.