Bug 1460743 - Tracker bug -- 7.3.6 respin of sssd-docker
Tracker bug -- 7.3.6 respin of sssd-docker
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd-docker (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: SSSD Maintainers
sssd-qe
: Tracking
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 10:57 EDT by Lukas Slebodnik
Modified: 2017-06-28 11:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-28 11:45:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Slebodnik 2017-06-12 10:57:11 EDT
Tracking rebuild of sssd-docker.
Comment 3 Niranjan Mallapadi Raghavender 2017-06-23 08:46:45 EDT
Versions:
Host version = State: idle
Deployments:
● rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
             Version: 7.3.6 (2017-06-22 19:55:20)
              Commit: 40370ddd41b638cf0af9f632ae16e498fa8e86426b2fd36e74d5c632dd48429c

sssd-docker:7.3.26


Following Tests passed:
=======================
IDM-SSSD-TC: SSSD-Container: Discover Windows Domain on atomic host using realm cli	Passed
IDM-SSSD-TC: SSSD-Container: Disjoin Atomic host from AD Domain using realm leave Cli	Passed
IDM-SSSD-TC: SSSD-Container: Join AD Domain using adcli as membership-software	Passed
IDM-SSSD-TC: SSSD-Container: Query AD user using id command from new container	Passed
IDM-SSSD-TC: SSSD-Container: Query AD users using ID command                   Passed
IDM-SSSD-TC: SSSD-Container: Realm join with membership software samba	Passed
IDM-SSSD-TC: SSSD-Container: Verify sssd selinux label	1 min 18 sec	Passed
IDM-SSSD-TC: SSSD-Container: Verify uninstall container leaves domain	Passed
Comment 5 Niranjan Mallapadi Raghavender 2017-06-23 10:15:23 EDT
Re-Run the tests with new Atomic Host build.

Host version = State: idle
Deployments:
● rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
             Version: 7.3.6 (2017-06-22 22:52:36)
              Commit: 692aa8cada83b0a3fc51ea423abcfc7de585e4200f3a87d76f1ce379d46068b1


sssd-docker:7.3.26


Following Tests passed:
=======================
IDM-SSSD-TC: SSSD-Container: Discover Windows Domain on atomic host using realm cli	Passed
IDM-SSSD-TC: SSSD-Container: Disjoin Atomic host from AD Domain using realm leave Cli	Passed
IDM-SSSD-TC: SSSD-Container: Join AD Domain using adcli as membership-software	Passed
IDM-SSSD-TC: SSSD-Container: Query AD user using id command from new container	Passed
IDM-SSSD-TC: SSSD-Container: Query AD users using ID command                   Passed
IDM-SSSD-TC: SSSD-Container: Realm join with membership software samba	Passed
IDM-SSSD-TC: SSSD-Container: Verify sssd selinux label	1 min 18 sec	Passed
IDM-SSSD-TC: SSSD-Container: Verify uninstall container leaves domain	Passed
Comment 6 Nikhil Dehadrai 2017-06-23 13:25:23 EDT
Tested bug w.r.t IPA.

IPA server : ipa-server-4.4.0-14.el7_3.7.x86_64
IPA-Client Version: ipa-client-4.4.0-14.el7_3.7.x86_64
sssd-container image: sssd-docker-7.3.26

atomic host status:
State: idle
Deployments:
● atomic-host:rhel-atomic-host/7/x86_64/standard
             Version: 7.3.6 (2017-06-22 22:52:36)
              Commit: 692aa8cada83b0a3fc51ea423abcfc7de585e4200f3a87d76f1ce379d46068b1


Verified the bug with following scenarios:
1. Verified that IPA-client is installed through sssd-container image.
2. Verified that klist works when ipa-client is configured with sssd-container image.
3. Verified that ipa-user/ windows AD user details can be viewed from client machine.
4. Verified that SSH works when IPA-client is configured with sssd-container image.
5. Verified that latest version of ipa-client is available with sssd-container image.
6. Verified that IPA-client can be uninstalled.

Thus on the basis of above observations marking status of bug to "VERIFIED".
Comment 8 Niranjan Mallapadi Raghavender 2017-06-23 17:30:09 EDT
Host version = State: idle
Deployments:
● rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
             Version: 7.3.6 (2017-06-23 16:20:45)
              Commit: e073a47baa605a99632904e4e05692064302afd8769a15290d8ebe8dbfd3c81b


sssd-docker:7.3.26


Following Tests passed:
=======================
IDM-SSSD-TC: SSSD-Container: Discover Windows Domain on atomic host using realm cli	Passed
IDM-SSSD-TC: SSSD-Container: Disjoin Atomic host from AD Domain using realm leave Cli	Passed
IDM-SSSD-TC: SSSD-Container: Join AD Domain using adcli as membership-software	Passed
IDM-SSSD-TC: SSSD-Container: Query AD user using id command from new container	Passed
IDM-SSSD-TC: SSSD-Container: Query AD users using ID command                   Passed
IDM-SSSD-TC: SSSD-Container: Realm join with membership software samba	Passed
IDM-SSSD-TC: SSSD-Container: Verify sssd selinux label	1 min 18 sec	Passed
IDM-SSSD-TC: SSSD-Container: Verify uninstall container leaves domain	Passed
Comment 10 errata-xmlrpc 2017-06-28 11:45:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1645

Note You need to log in before you can comment on or make changes to this bug.