Bug 146077 - Kernel oops (buffered_rmqueue)
Kernel oops (buffered_rmqueue)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-25 02:58 EST by Bradley
Modified: 2015-01-04 17:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-16 09:37:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bradley 2005-01-25 02:58:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
Kernel oopsed, and machine becaume unreachable, requiring somone to powercycle it. This has happened a few times before. (This isn't the same machine as bug 144753). I was on my way home from work, so noone was touching anything - I'm not sure what hotplug was doing anything.

Its locked up a few times recently, but this is the first time there as an oops in the logs. I ran memtest86 without problems after the first time. The machine was someone else's at work, but he left and I got it; I'm not aware that he had any problems, so I don't think its hardware related.

logs are:

Jan 25 17:25:16 bradley dbus: avc:  0 AV entries and 0/512 buckets used, longest chain length 0
Jan 25 17:25:16 bradley gconfd (bbaetz-4334): Received signal 15, shutting down cleanly
Jan 25 17:25:16 bradley gdm[4139]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
Jan 25 17:25:16 bradley gdm(pam_unix)[4139]: session closed for user bbaetz
Jan 25 17:25:16 bradley gconfd (bbaetz-4334): Exiting
Jan 25 17:25:17 bradley kernel: Unable to handle kernel paging request at virtual address 00100104
Jan 25 17:25:17 bradley kernel:  printing eip:
Jan 25 17:25:17 bradley kernel: c014115f
Jan 25 17:25:17 bradley kernel: *pde = 1207d067
Jan 25 17:25:17 bradley kernel: Oops: 0002 [#1]
Jan 25 17:25:17 bradley kernel: Modules linked in: md5 ipv6 parport_pc lp parport autofs4 nfs lockd sunrpc ipt_LOG ipt_state ip_conntrack iptable_filter ip_tables microcode dm_mod video button battery ac ohci_hcd i2c_sis96x i2c_core snd_intel8x0 snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_alloc e100 mii floppy ext3 jbd
Jan 25 17:25:17 bradley kernel: CPU:    0
Jan 25 17:25:17 bradley kernel: EIP:    0060:[<c014115f>]    Not tainted VLI
Jan 25 17:25:17 bradley kernel: EFLAGS: 00010006   (2.6.10-1.741_FC3)
Jan 25 17:25:17 bradley kernel: EIP is at buffered_rmqueue+0x61/0x1e3
Jan 25 17:25:17 bradley kernel: eax: c12416f8   ebx: c0347954   ecx: c0347980   edx: 00100100
Jan 25 17:25:17 bradley kernel: esi: c0347954   edi: c0347970   ebp: 00000000   esp: d2eabe5c
Jan 25 17:25:17 bradley kernel: ds: 007b   es: 007b   ss: 0068
Jan 25 17:25:17 bradley kernel: Process default.hotplug (pid: 6571, threadinfo=d2eab000 task=d6bb21b0)
Jan 25 17:25:17 bradley kernel: Stack: c12416e0 00000246 000000d2 c0347954 00000000 000000d2 c0347c1c c014138d
Jan 25 17:25:17 bradley kernel:        00000001 00000000 d6bb21b0 00000010 00000000 c0152250 00000000 d20b9a88
Jan 25 17:25:17 bradley kernel:        c5528bfc d5e84380 c014cb05 d2c6baa4 d6bb21b0 c0115072 00000001 00000001
Jan 25 17:25:17 bradley kernel: Call Trace:
Jan 25 17:25:17 bradley kernel:  [<c014138d>] __alloc_pages+0xac/0x28e
Jan 25 17:25:17 bradley kernel:  [<c0152250>] anon_vma_prepare+0x18/0x1b8
Jan 25 17:25:17 bradley kernel:  [<c014cb05>] do_wp_page+0x1d6/0x424
Jan 25 17:25:17 bradley kernel:  [<c0115072>] do_page_fault+0x192/0x4cb
Jan 25 17:25:17 bradley kernel:  [<c014dd19>] handle_mm_fault+0x121/0x1fd
Jan 25 17:25:17 bradley kernel:  [<c0115072>] do_page_fault+0x192/0x4cb
Jan 25 17:25:17 bradley kernel:  [<c0114ee0>] do_page_fault+0x0/0x4cb
Jan 25 17:25:17 bradley kernel:  [<c0103513>] error_code+0x2b/0x30
Jan 25 17:25:18 bradley kernel:  [<c0117136>] schedule_tail+0x48/0x4e
Jan 25 17:25:18 bradley kernel:  [<c0114ee0>] do_page_fault+0x0/0x4cb


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.741_FC3

How reproducible:
Sometimes

Steps to Reproduce:
1. Unsure

Actual Results:  System was not pingable.

Expected Results:  System kept running...

Additional info:
Comment 1 Bradley 2005-02-01 01:11:01 EST
System hung again. sysreq-T showed:

Feb  1 16:34:42 bradley kernel:                                      
         sibling
Feb  1 16:34:42 bradley kernel:   task             PC      pid father
child younger older
Feb  1 16:34:42 bradley kernel: init          S C01412BE   892     1 
    0     2               (NOTLB)
Feb  1 16:34:42 bradley kernel: c14e7eb0 00000082 00000055 c01412be
d4106e70 00000000 43341bc0 000fac41
Feb  1 16:34:42 bradley kernel:        dff115b0 dff1173c 06f28b3f
06f28b3f 00000800 c14e7f74 c02f5788 c03462b8
Feb  1 16:34:42 bradley kernel:        d8906eb8 06f28b3f 1d244b3c
00000000 00000005 c0303e2d c0306034 000000a7
Feb  1 16:34:42 bradley kernel: Call Trace:
Feb  1 16:34:42 bradley kernel:  [<c01412be>] buffered_rmqueue+0x1c0/0x1e3
Feb  1 16:34:42 bradley kernel:  [<c02f5788>] schedule_timeout+0xb4/0xcf
Feb  1 16:34:42 bradley kernel:  [<c0124094>] process_timeout+0x0/0x5
Feb  1 16:34:42 bradley kernel:  [<c016b0fc>] pipe_poll+0x2c/0x6a
Feb  1 16:34:42 bradley kernel:  [<c0171233>] do_select+0x321/0x352
Feb  1 16:34:42 bradley kernel:  [<c0170dd9>] __pollwait+0x0/0x94
Feb  1 16:34:42 bradley kernel:  [<c0171584>] sys_select+0x30d/0x49e
Feb  1 16:34:42 bradley kernel:  [<c010336b>] syscall_call+0x7/0xb
Feb  1 16:34:42 bradley kernel: ksoftirqd/0   S 000FA82E  3812     2 
    1             3       (L-TLB)
Feb  1 16:34:42 bradley kernel: c14eafc4 00000046 0516c480 000fa82e
d149ec70 00000000 bfce1500 000faa66
Feb  1 16:34:42 bradley kernel:        dff11050 dff111dc c14ea000
c14e7f64 00000000 c01206a0 c01206d5 c14ea000
Feb  1 16:34:42 bradley kernel:        c01314fd fffffffc ffffffff
ffffffff c0131494 00000000 00000000 00000000
Feb  1 16:34:42 bradley kernel: Call Trace:
Feb  1 16:34:42 bradley kernel:  [<c01206a0>] ksoftirqd+0x0/0x92
Feb  1 16:34:42 bradley kernel:  [<c01206d5>] ksoftirqd+0x35/0x92
Feb  1 16:34:42 bradley kernel:  [<c01314fd>] kthread+0x69/0x91
Feb  1 16:34:42 bradley kernel:  [<c0131494>] kthread+0x0/0x91
Feb  1 16:34:42 bradley kernel:  [<c01011dd>] kernel_thread_helper+0x5/0xb
Feb  1 16:34:42 bradley kernel: events/0      R running  2880     3  
   1     4     107     2 (L-TLB)
Feb  1 16:34:42 bradley kernel: khelper       S DFFEA6C8  3328     4 
    3            16       (L-TLB)
Feb  1 16:34:42 bradley kernel: dffdff6c 00000046 00000003 dffea6c8
dabab930 00000000 4de131c0 000f58c7
Feb  1 16:34:42 bradley kernel:        dff10590 dff1071c cae79e0c
00000246 cae79e5c dffea680 c012c9ff c012c663
Feb  1 16:34:42 bradley kernel:        ffffffff ffffffff 00000001
00000000 c0117643 00010000 00000000 dff10590
Feb  1 16:34:42 bradley kernel: Call Trace:
Feb  1 16:34:42 bradley kernel:  [<c012c9ff>] worker_thread+0xca/0x2f0
Feb  1 16:34:42 bradley kernel:  [<c012c663>]
__call_usermodehelper+0x0/0x41
Feb  1 16:34:42 bradley kernel:  [<c0117643>]
default_wake_function+0x0/0xc
Feb  1 16:34:42 bradley kernel:  [<c02f4f15>] schedule+0x453/0x4d6
Feb  1 16:34:42 bradley kernel:  [<c0117643>]
default_wake_function+0x0/0xc
Feb  1 16:34:42 bradley kernel:  [<c012c935>] worker_thread+0x0/0x2f0
Feb  1 16:34:42 bradley kernel:  [<c01314fd>] kthread+0x69/0x91
Feb  1 16:34:42 bradley kernel:  [<c0131494>] kthread+0x0/0x91
Feb  1 16:34:42 bradley kernel:  [<c01011dd>] kernel_thread_helper+0x5/0xb
Feb  1 16:34:42 bradley kernel: kacpid        S DFF10030  3820    16 
    3            99     4 (L-TLB)
Feb  1 16:34:42 bradley kernel: dffddf6c 00000046 00000000 dff10030
dfc0d630 00000000 ea49e2c0 000f41fa
Feb  1 16:34:42 bradley kernel:        dff10030 dff101bc dffdd000
dffddf80 dffddf94 dffcc480 c012c9ff 00000001
Feb  1 16:34:42 bradley kernel:        ffffffff ffffffff 00000001
00000000 c0117643 00010000 00000000 dff10030
Feb  1 16:34:42 bradley kernel: Call Trace:
Feb  1 16:34:42 bradley kernel:  [<c012c9ff>] worker_thread+0xca/0x2f0
Feb  1 16:34:42 bradley kernel:  [<c0117643>]
default_wake_function+0x0/0xc
Feb  1 16:34:42 bradley kernel:  [<c02f4f15>] schedule+0x453/0x4d6
Feb  1 16:34:42 bradley kernel:  [<c0117643>]
default_wake_function+0x0/0xc
Feb  1 16:34:42 bradley kernel:  [<c012c935>] worker_thread+0x0/0x2f0
Feb  1 16:34:42 bradley kernel:  [<c01314fd>] kthread+0x69/0x91
Feb  1 16:34:42 bradley kernel:  [<c0131494>] kthread+0x0/0x91
Feb  1 16:34:42 bradley kernel:  [<c01011dd>] kernel_thread_helper+0x5/0xb
Feb  1 16:34:42 bradley kernel: kblockd/0     S DFE7BBC8  3516    99 
    3           166    16 (L-TLB)
Feb  1 16:34:42 bradley kernel: dfc20f6c 00000046 00000003 dfe7bbc8
d4106e70 00000000 00123880 000fac38
Feb  1 16:34:42 bradley kernel:        dfc0d0d0 dfc0d25c dfc9bdf0
00000202 dfc9bd10 dfe7bb80 c012c9ff c023e65a
Feb  1 16:34:42 bradley kernel:        ffffffff ffffffff 00000001
00000000 c0117643 00010000 00000000 dfc0d0d0
Feb  1 16:34:42 bradley kernel: Call Trace:
Feb  1 16:34:42 bradley kernel:  [<c012c9ff>] worker_thread+0xca/0x2f0
Feb  1 16:34:42 bradley kernel:  [<c023e65a>] blk_unplug_work+0x0/0x9
Feb  1 16:34:42 bradley kernel:  [<c0117643>]
default_wake_function+0x0/0xc
Feb  1 16:34:42 bradley kernel:  [<c02f4f15>] schedule+0x453/0x4d6
Feb  1 16:34:42 bradley kernel:  [<c0117643>]
default_wake_function+0x0/0xc
Feb  1 16:34:42 bradley kernel:  [<c012c935>] worker_thread+0x0/0x2f0
Feb  1 16:34:42 bradley kernel:  [<c01314fd>] kthread+0x69/0x91
Feb  1 16:34:42 bradley kernel:  [<c0131494>] kthread+0x0/0x91
Feb  1 16:34:42 bradley kernel:  [<c01011dd>] kernel_thread_helper+0x5/0xb
Feb  1 16:34:42 bradley kernel: khubd         S DCC2EC00  3460   107 
    1           165     3 (L-TLB)
Feb  1 16:34:42 bradley kernel: dfc35fa4 00000046 dc607200 dcc2ec00
dd6d01b0 00000000 39188000 000f4200
Feb  1 16:34:42 bradley kernel:        dfc0cb70 dfc0ccfc c02739ae
00000000 dfc35fc0 00000000 c0273a4d 00000000
Feb  1 16:34:42 bradley kernel:        dfc0cb70 c0131ca2 dfc35fd8
dfc35fd8 dff10af0 c02739ae 00000000 00000000
Feb  1 16:34:42 bradley kernel: Call Trace:
Feb  1 16:34:42 bradley kernel:  [<c02739ae>] hub_thread+0x0/0xe4
Feb  1 16:34:42 bradley kernel:  [<c0273a4d>] hub_thread+0x9f/0xe4
Feb  1 16:34:42 bradley kernel:  [<c0131ca2>]
autoremove_wake_function+0x0/0x2d
Feb  1 16:34:42 bradley kernel:  [<c02739ae>] hub_thread+0x0/0xe4
Feb  1 16:34:42 bradley kernel:  [<c0131ca2>]
autoremove_wake_function+0x0/0x2d
Feb  1 16:34:42 bradley kernel:  [<c01011dd>] kernel_thread_helper+0x5/0xb
Feb  1 16:34:42 bradley kernel: aio/0         S DFC71150  3820   166 
    3          5076    99 (L-TLB)
Feb  1 16:34:42 bradley kernel: dfc49f6c 00000046 00000000 dfc71150
dfc716b0 00000000 f3687b00 000f41fa
Feb  1 16:34:42 bradley kernel:        dfc71150 dfc712dc dfc49000
dfc49f80 dfc49f94 dfe7b480 c012c9ff 00000001
Feb  1 16:34:42 bradley kernel:        ffffffff ffffffff 00000001
00000000 c0117643 00010000 00000000 dfc71150
Feb  1 16:34:42 bradley kernel: Call Trace:
Feb  1 16:34:42 bradley kernel:  [<c012c9ff>] worker_thread+0xca/0x2f0
Feb  1 16:34:42 bradley kernel:  [<c0117643>]
default_wake_function+0x0/0xc
Feb  1 16:34:42 bradley kernel:  [<c02f4f15>] schedule+0x453/0x4d6
Feb  1 16:34:42 bradley kernel:  [<c0117643>]
default_wake_function+0x0/0xc
Feb  1 16:34:42 bradley kernel:  [<c012c935>] worker_thread+0x0/0x2f0
Feb  1 16:34:42 bradley kernel:  [<c01314fd>] kthread+0x69/0x91
Feb  1 16:34:42 bradley kernel:  [<c0131494>] kthread+0x0/0x91
Feb  1 16:34:42 bradley kernel:  [<c01011dd>] kernel_thread_helper+0x5/0xb
Feb  1 16:34:42 bradley kernel: kswapd0       S 0000007B  2936   165 
    1           257   107 (L-TLB)
Feb  1 16:34:42 bradley kernel: dfc36f94 00000046 0000001f 0000007b
d4106e70 00030d40 c3037680 000f9fde
Feb  1 16:34:42 bradley kernel:        dfc716b0 dfc7183c dfc36fc0
c0347c4c dfc36fb4 c0347800 c0149799 0000001b
Feb  1 16:34:42 bradley kernel:        00000000 dfc716b0 c0131ca2
dfc36fcc dfc36fcc dfc716b0 c03ce1a0 dfc36000
Feb  1 16:34:42 bradley kernel: Call Trace:
Feb  1 16:34:42 bradley kernel:  [<c0149799>] kswapd+0xa7/0xbb
Feb  1 16:34:42 bradley kernel:  [<c0131ca2>]
autoremove_wake_function+0x0/0x2d
Feb  1 16:34:42 bradley kernel:  [<c0131ca2>]
autoremove_wake_function+0x0/0x2d
Feb  1 16:34:42 bradley kernel:  [<c01496f2>] kswapd+0x0/0xbb
Feb  1 16:34:42 bradley kernel:  [<c01011dd>] kernel_thread_helper+0x5/0xb
Feb  1 16:34:42 bradley kernel: kseriod       S C0124584  3876   257 
    1           450   165 (L-TLB)
Feb  1 16:34:42 bradley kernel: dfc16fa4 00000046 dfc16000 c0124584
dff115b0 00000000 1c1e3bc0 000f41fb
Feb  1 16:34:42 bradley kernel:        dfc0d630 dfc0d7bc c022f293
00000000 dfc16fc0 00000000 c022f332 00000000
Feb  1 16:34:42 bradley kernel:        dfc0d630 c0131ca2 dfc16fd8
dfc16fd8 dff10af0 c022f293 00000000 00000000
Feb  1 16:34:42 bradley kernel: Call Trace:
Feb  1 16:34:42 bradley kernel:  [<c0124584>] free_uid+0x15/0xbc
Feb  1 16:34:42 bradley kernel:  [<c022f293>] serio_thread+0x0/0xef
Feb  1 16:34:42 bradley kernel:  [<c022f332>] serio_thread+0x9f/0xef
Feb  1 16:34:42 bradley kernel:  [<c0131ca2>]
autoremove_wake_function+0x0/0x2d
Feb  1 16:34:42 bradley kernel:  [<c022f293>] serio_thread+0x0/0xef
Feb  1 16:34:42 bradley kernel:  [<c0131ca2>]
autoremove_wake_function+0x0/0x2d
Feb  1 16:34:42 bradley kernel:  [<c01011dd>] kernel_thread_helper+0x5/0xb
Feb  1 16:34:42 bradley kernel: kjournald     S DFD386A4  2568   450 
    1          1435   257 (L-TLB)
Feb  1 16:34:42 bradley kernel: dfdd1f54 00000046 00000003 dfd386a4
dcc94af0 00000000 8fdae940 000fac41
Feb  1 16:34:42 bradley kernel:        dfc70130 dfc702bc dfdd1f80
dfd38600 00000001 00000000 e084e4b3 00000000
Feb  1 16:34:42 bradley kernel:        00000000 dfc70130 c0131ca2
dfdd1f8c dfdd1f8c 00000000 00000000 00000000
Feb  1 16:34:42 bradley kernel: Call Trace:
Feb  1 16:34:42 bradley kernel:  [<e084e4b3>] kjournald+0x381/0x4aa [jbd]
Feb  1 16:34:42 bradley kernel:  [<c0131ca2>]
autoremove_wake_function+0x0/0x2d
Feb  1 16:34:42 bradley kernel:  [<c0131ca2>]
autoremove_wake_function+0x0/0x2d
Feb  1 16:34:42 bradley kernel:  [<e084e12c>] commit_timeout+0x0/0x5 [jbd]
Feb  1 16:34:42 bradley kernel:  [<e084e132>] kjournald+0x0/0x4aa [jbd]
Feb  1 16:34:42 bradley kernel:  [<c01011dd>] kernel_thread_helper+0x5/0xb
Feb  1 16:34:42 bradley kernel: udevd         S C01412BE  3052  1435 
    1          2618   450 (NOTLB)
Feb  1 16:34:42 bradley kernel: dcaf0eb0 00000082 00000055 c01412be
c1143580 00000000 55ce9d00 000f58c7
Feb  1 16:34:42 bradley kernel:        dcf711d0 dcf7135c dd0dce80
7fffffff 00000040 dcaf0f74 c02f56e7 00000010
Feb  1 16:34:42 bradley kernel:        00000000 0a01e388 dcd68980
00000000 dcaf0f58 00000246 dd22a580 dcaf0f58

However, even though I did a sysreq-S, I don't think it all got to
logs....
Comment 2 Dave Jones 2005-07-15 15:06:10 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Bradley 2005-07-16 09:37:21 EDT
Havne't seen this on fc4

Note You need to log in before you can comment on or make changes to this bug.