Bug 1460770 - SELinux is preventing tumblerd from write access on the sock_file socket.
SELinux is preventing tumblerd from write access on the sock_file socket.
Status: CLOSED DUPLICATE of bug 1398849
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
25
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Vrabec
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 12:39 EDT by Alan Schmidt
Modified: 2017-06-14 16:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-14 16:30:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Schmidt 2017-06-12 12:39:47 EDT
Description of problem:
Tumblerd produces an SELinux error:

SELinux is preventing tumblerd from write access on the sock_file socket.

Version-Release number of selected component (if applicable):
tumbler-0.1.31-3.fc24.x86_64

How reproducible:
Upon login

Steps to Reproduce:
Login

Actual results:
Error appears on login

Expected results:
No error appears on login


Additional info:
The remediation steps to set up a PERSONAL exception produce a my-tumblerd.te that looks like this:

module my-tumblerd 1.0;

require {
        type thumb_t;
        type syslogd_var_run_t;
        class unix_dgram_socket create;
        class sock_file write;
}

#============= thumb_t ==============
allow thumb_t self:unix_dgram_socket create;
allow thumb_t syslogd_var_run_t:sock_file write;


Bug 1398849 may be related. That bug is filed against SELinux.
Comment 1 Kevin Fenzi 2017-06-14 16:30:25 EDT
Yeah, thats the same bug I think...

*** This bug has been marked as a duplicate of bug 1398849 ***

Note You need to log in before you can comment on or make changes to this bug.