Bug 1460860 - Catalog Item Icon not displayed in Global region
Catalog Item Icon not displayed in Global region
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Replication (Show other bugs)
5.7.0
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: Gregg Tanzillo
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 20:58 EDT by Brant Evans
Modified: 2017-07-31 10:28 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-31 10:28:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Regional Catalog Item Screenshot (46.91 KB, image/png)
2017-06-12 20:58 EDT, Brant Evans
no flags Details
Global Catalog Item Screenshot (45.40 KB, image/png)
2017-06-12 20:59 EDT, Brant Evans
no flags Details
Global Catalog Item Details Screenshot (90.67 KB, image/png)
2017-06-12 20:59 EDT, Brant Evans
no flags Details

  None (edit)
Description Brant Evans 2017-06-12 20:58:29 EDT
Description of problem:
Catalog Item Icons from a sub-region are not visible in the Global region.

I have attached screenshots showing the catalog item in the sub-region and when viewed in the Global Region

Version-Release number of selected component (if applicable):
5.7.2

How reproducible:
Always

Steps to Reproduce:
1. Setup CloudForms in a multi-region configuration with Central Management enabled
2. Create a catalog item in the sub-region
3. Add an icon to the catalog item in the sub-region
4. View the catalog item in the Global region

Actual results:
Catalog Item icon is not displayed

Expected results:
Catalog Item icon is shown

Additional info:
Comment 2 Brant Evans 2017-06-12 20:58 EDT
Created attachment 1287133 [details]
Regional Catalog Item Screenshot
Comment 3 Brant Evans 2017-06-12 20:59 EDT
Created attachment 1287134 [details]
Global Catalog Item Screenshot
Comment 4 Brant Evans 2017-06-12 20:59 EDT
Created attachment 1287135 [details]
Global Catalog Item Details Screenshot
Comment 7 Dustin Scott 2017-07-03 09:19:06 EDT
+1 for this bug.  This is also a problem at my current customer.
Comment 8 Nick Carboni 2017-07-31 10:28:53 EDT
The icons for services are stored in the binary_blob and binary_blob_parts tables.

We do not replicate these tables by default because they also contain rather large content such as all the report results which would cause confusion with reports run in the global region.

I think that replicating this data would cause more issues than it would solve.

To me, this sounds like a non-urgent issue as I would think you could just upload the image on the global region, so I'm going to close this as WONTFIX.

If this is higher priority than it sounds we might be able to figure something out, but as of now, the risks seem to outweigh the rewards for a medium priority bug.

Note You need to log in before you can comment on or make changes to this bug.