Bug 14609 - RFE:Kickstart install can't remove packages from standard config
Summary: RFE:Kickstart install can't remove packages from standard config
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
: 13863 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-25 11:00 UTC by Paul Flinders
Modified: 2007-03-27 03:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-03 15:54:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Flinders 2000-07-25 11:00:08 UTC
The %packages section of a kickstart config file
only has syntax for adding packages, not removing
them

I know that sounds odd at first but it would be
useful to be able to say something like

%packages
@ GNOME Workstation
-jade

To have the standard "GNOME Workstation" install
but without jade (or some other small number of
packages).

The work around is to remove the package in the
post install script but including it only to remove
it lengthens the install (which is significant if
you have a lot of machines to do).

Comment 1 Michael Fulbright 2000-07-25 13:52:52 UTC
Added to feature request list.

Comment 2 Michael Fulbright 2000-09-14 21:52:13 UTC
*** Bug 13863 has been marked as a duplicate of this bug. ***

Comment 3 Michael Fulbright 2000-09-26 16:11:01 UTC
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED

Comment 4 Michael Fulbright 2000-09-26 16:56:42 UTC
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED

Comment 5 Michael Fulbright 2000-11-03 15:54:17 UTC
Thank you for the suggestion but this feature is not something  we plan on
implementing.


Note You need to log in before you can comment on or make changes to this bug.