Bug 1461112 - SS Dialogs don't honour drop-down defaults
SS Dialogs don't honour drop-down defaults
Status: CLOSED DUPLICATE of bug 1516721
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - Service (Show other bugs)
5.8.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.9.0
Assigned To: Allen W
Shveta
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-13 10:12 EDT by Jeff Warnica
Modified: 2018-02-15 09:45 EST (History)
9 users (show)

See Also:
Fixed In Version: 5.9.0.1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-04 07:43:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
if ya look real close at the tiny field i have highlighted in the ss, sui isn't receiving a default value, this bug is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1516721 (929.82 KB, image/png)
2017-12-04 07:41 EST, Allen W
no flags Details

  None (edit)
Description Jeff Warnica 2017-06-13 10:12:23 EDT
Per summary, if a drop-down field has a default set, the Self Service UI does not honour it; a blank option is created and is at the top of the generated HTML and the implicit default.
Comment 2 Allen W 2017-06-14 15:03:40 EDT
Can you please provide a vm ip forrrrrrr replication purposes?
Comment 4 Chris Kacerguis 2017-06-14 17:33:33 EDT
A Pivotal Tracker story has been created for this Bug: https://www.pivotaltracker.com/story/show/147234041
Comment 5 Allen W 2017-06-20 11:35:02 EDT
Hmm I believe this is satisfied by https://github.com/ManageIQ/manageiq-ui-service/pull/821 anyone able to confirm?
Comment 6 Chris Kacerguis 2017-06-20 11:35:22 EDT
Allen added a comment in Pivotal Tracker:   
   
believe this is satisfied by https://github.com/ManageIQ/manageiq-ui-service/pull/821
Comment 7 Shveta 2017-12-01 16:33:57 EST
Not fixed in  5.9.0.11.20171127204214_e316988 .
Appliance : https://10.8.197.145.
Service - dynamic.
Comment 8 Allen W 2017-12-04 07:41 EST
Created attachment 1362659 [details]
if ya look real close at the tiny field i have highlighted in the ss, sui isn't receiving a default value, this bug is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1516721
Comment 9 Allen W 2017-12-04 07:43:30 EST
@Shveta, looks like this is a duplicate of the following bug, sui isn't receiving the default field, cuz ops isn't saving it, all should be well once that bz is resolved 

https://bugzilla.redhat.com/show_bug.cgi?id=1516721

*** This bug has been marked as a duplicate of bug 1516721 ***

Note You need to log in before you can comment on or make changes to this bug.