Bug 1461213 - [RFE]Ansible Git repo provider connection using https_proxy option from CloudForms 4.5.*
[RFE]Ansible Git repo provider connection using https_proxy option from Cloud...
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.8.0
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: James Wong
Dave Johnson
: FutureFeature
: 1447996 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-13 19:10 EDT by tachoi
Modified: 2017-07-17 19:22 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-17 19:22:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Ansible


Attachments (Terms of Use)

  None (edit)
Description tachoi 2017-06-13 19:10:03 EDT
Description of problem:
- CFME appliance(5.8) is located behind squid proxy(no direct internet connection), need a proxy config option to connect Ansible Git repo 
- Ansible Git repository configuration(Automation > Ansible > Repositories)

Version-Release number of selected component (if applicable):
- CFME 5.8.0

How reproducible:
- NA

Steps to Reproduce:
1. Tried to set Ansible git repo https_proxy from Advance config in UI 
2. No proxy option is available for Ansible git repo
3.

Actual results:
No proxy option available for Ansible git repo

Expected results:
Expecting something like below from advanced config.

...
:http(s)_proxy:
  :Ansible_git:
    :host: 
    :password: 
    :port: 
    :user:
...


Additional info:
All of CF 4.5 appliances doesn't have direct internet connection and behind squid proxy server
Comment 8 Bronagh Sorota 2017-06-27 10:43:03 EDT
*** Bug 1447996 has been marked as a duplicate of this bug. ***
Comment 15 James Wong 2017-07-17 19:22:00 EDT
Thanks Taeho!

Closing...

Note You need to log in before you can comment on or make changes to this bug.