Bug 1461215 - redhat-upgrade-tool craches when upgrading to RHEL7.4
redhat-upgrade-tool craches when upgrading to RHEL7.4
Status: CLOSED DUPLICATE of bug 1456809
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: redhat-upgrade-tool (Show other bugs)
6.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michal Bocek
Release Test Team
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-13 19:30 EDT by Andrej Manduch
Modified: 2017-06-16 06:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-16 06:17:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrej Manduch 2017-06-13 19:30:11 EDT
Description of problem:
When I tried to upgrade from RHEL6.9 to RHEL7.4 It will fail without error message describing what's wrong it will just print out Traceback.

Traceback (most recent call last):
  File "/usr/bin/redhat-upgrade-tool", line 432, in <module>
    main(args)
  File "/usr/bin/redhat-upgrade-tool", line 254, in main
    if f.treeinfo.get('product', 'name') == 'Red Hat Enterprise Linux':
  File "/usr/lib64/python2.6/ConfigParser.py", line 321, in get
    raise NoSectionError(section)
ConfigParser.NoSectionError: No section: 'product


Version-Release number of selected component (if applicable):

[root@intel-hermosabeach-01 ~]# rpm -qa redhat-upgrade-tool
redhat-upgrade-tool-0.7.48-1.el6.noarch
[root@intel-hermosabeach-01 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.9 (Santiago)
[root@intel-hermosabeach-01 ~]# hostname 
intel-hermosabeach-01.khw.lab.eng.bos.redhat.com
[root@intel-hermosabeach-01 ~]# md5sum RHEL-7.4-20170609.n.0-Server-x86_64-dvd1.iso 
e2103698b11728ff6984148b07e03564  RHEL-7.4-20170609.n.0-Server-x86_64-dvd1.iso

How reproducible:
Every time

Steps to Reproduce:
Use https://access.redhat.com/solutions/637583 upgrade guide as manual for RHEL6 > RHEL7 upgrade

Download newest RHEL7 nightly build:
wget http://download-node-02.eng.bos.redhat.com/nightly/RHEL-7.4-20170609.n.0/compose/Server/x86_64/iso/RHEL-7.4-20170609.n.0-Server-x86_64-dvd1.iso

run 
redhat-upgrade-tool --iso ./RHEL-7.4-20170609.n.0-Server-x86_64-boot.iso


And it will crash on this message:
preupg.risk.SLIGHT: Repo beaker-Server-SAPHANA is enabled.
preupg.risk.SLIGHT: Repo beaker-Server-SAP is enabled.
preupg.risk.SLIGHT: Repo beaker-Server-optional is enabled.
preupg.risk.SLIGHT: Repo beaker-Server-SAP-debuginfo is enabled.
preupg.risk.SLIGHT: Enabled repo files for kickstart generation are stored in /root/preupgrade/kickstart/available-repos.
preupg.risk.MEDIUM: having one of the following packages installed might break the upgrade: python-requests libXv nspr nss-util vim-enhanced python-rhsm libxcb libXi libXtst libX11-devel openscap-scanner java-1.8.0-openjdk vim-minimal li
bX11-common vim-filesystem python-urllib3 xorg-x11-proto-devel json-c openldap grep vim-common libX11 libXrender libXfixes libxcb-devel libXfixes-devel libXi-devel libXrandr-devel nss-sysinit nss-tools python-dmidecode mesa-libGLU-devel 
redhat-access-insights nss-devel libXtst-devel openscap java-1.8.0-openjdk-headless openscap-engine-sce mesa-libGLU python-backports-ssl_match_hostname python-rhsm-certificates subscription-manager openldap-devel satyr nspr-devel libXran
dr libXrender-devel nss-util-devel openscap-utils kpartx nss ca-certificates
preupg.risk.SLIGHT: The 'export' commands will be removed from the /etc/sysconfig/sshd file.
Continue with the upgrade [Y/N]? y
Traceback (most recent call last):
  File "/usr/bin/redhat-upgrade-tool", line 432, in <module>
    main(args)
  File "/usr/bin/redhat-upgrade-tool", line 254, in main
    if f.treeinfo.get('product', 'name') == 'Red Hat Enterprise Linux':
  File "/usr/lib64/python2.6/ConfigParser.py", line 321, in get
    raise NoSectionError(section)
ConfigParser.NoSectionError: No section: 'product'


Expected results:
Upgrade system or print out error message not Traceback.

Additional info:

I also tried to perform upgrade with using --network and pointing it out to remote repository, but it crashed with same traceback.
Comment 2 Michal Bocek 2017-06-16 06:17:02 EDT
Andrej, it has been also reported in RHBZ#1456809 and it's been fixed in upstream: https://github.com/upgrades-migrations/redhat-upgrade-tool/pull/21

*** This bug has been marked as a duplicate of bug 1456809 ***

Note You need to log in before you can comment on or make changes to this bug.