Bug 1461309 - Invalid type signature for org.ovirt.engine.core.common.action.VdcActionType
Invalid type signature for org.ovirt.engine.core.common.action.VdcActionType
Status: CLOSED WORKSFORME
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.0
: ---
Assigned To: Greg Sheremeta
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 03:45 EDT by Petr Matyáš
Modified: 2017-06-21 11:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-21 11:06:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)
server log (2.45 MB, text/plain)
2017-06-14 03:45 EDT, Petr Matyáš
no flags Details

  None (edit)
Description Petr Matyáš 2017-06-14 03:45:50 EDT
Created attachment 1287552 [details]
server log

Description of problem:
Error is displayed on any action (edit, maintenance, upgrade...) on a host in 4.2 master

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.0-0.0.master.20170612192318.gitf773263.el7.centos.noarch

How reproducible:
always

Steps to Reproduce:
1. have 4.2 master with a host installed
2. try to put it to maintenance
3.

Actual results:
error is displayed

Expected results:
host action is successful

Additional info:
2017-06-14 10:35:38,775+03 ERROR [io.undertow.servlet] (default task-4) GenericApiServlet: An IncompatibleRemoteServiceException was thrown while processing this call.: com.google.gwt.user.client.rpc.IncompatibleRemoteServiceException: Invalid type signature for org.ovirt.engine.core.common.action.VdcActionType
Comment 1 Petr Matyáš 2017-06-14 03:48:41 EDT
My bad, it's happening for any action anywhere in webadmin.
Comment 2 Oved Ourfali 2017-06-15 01:22:53 EDT
Does it reproduce on latest master?
CC-ing Alexander.
Comment 3 Yaniv Kaul 2017-06-15 02:48:01 EDT
I've seen it happening on my laptop as well - can you try and clean the browser cache?
Comment 4 Petr Matyáš 2017-06-15 04:21:06 EDT
(In reply to Oved Ourfali from comment #2)
> Does it reproduce on latest master?
> CC-ing Alexander.

This is latest master.

(In reply to Yaniv Kaul from comment #3)
> I've seen it happening on my laptop as well - can you try and clean the
> browser cache?

I cleaned the browser cache, still reproduces.
I used different browser, still reproduces.
Comment 5 Petr Matyáš 2017-06-15 05:29:16 EDT
(In reply to Oved Ourfali from comment #2)
> Does it reproduce on latest master?
> CC-ing Alexander.

When using the new UI it's not happening (there are different bugs)
Comment 6 Petr Matyáš 2017-06-15 05:33:44 EDT
Ignore last comment, there weren't latest packages, so it's happening for the new UI as well.
Comment 12 Greg Sheremeta 2017-06-20 13:26:38 EDT
works for me. I'll investigate some more.
Comment 15 Petr Matyáš 2017-06-21 11:06:25 EDT
Can't reproduce either. I tried clean 4.2 env and upgraded env from 4.0 to 4.1 to 4.2, both work correctly. I have no idea what was wrong on the env I had earlier.

Note You need to log in before you can comment on or make changes to this bug.