Bug 1461318 - Packages uploaded in the custom repository does not reflect size in the webui.
Packages uploaded in the custom repository does not reflect size in the webui.
Status: CLOSED DUPLICATE of bug 1450113
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories (Show other bugs)
6.2.9
x86_64 Linux
medium Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 04:22 EDT by Ashish Humbe
Modified: 2017-09-22 15:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-22 15:12:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ashish Humbe 2017-06-14 04:22:55 EDT
Description of problem:

When we upload a new package to a custom repository from the satellite server webui, package get uploaded successfully. But when navigate to Content -> Packages and check the package details the package size is displayed as blank.

Version-Release number of selected component (if applicable):
Red Hat Satellite v 6.2.9

How reproducible:
Always

Steps to Reproduce:
1. Create custom product and repository in the Satellite v 6.2.9
2. Take some custom packages (which are not already synced on the satellite 6)
3. Upload packages in the repository via webui
4. Navigate to Content -> Packages -> Click on the package name and check the size.

It is displayed as :

Size ( Bytes)


Actual results:

Package size is not calculated so it is displayed as blank in the webui. 

Expected results:
Even if we upload the package manually the package size should be calculated and displayed correctly in the webui.


Workaround: 

- Copy custom packages in a directory 
- Create repodata using "createrepo" command 
- host this repository on the http and sync it on the satellite server in the custom repo created.
Comment 2 Ashish Humbe 2017-06-14 04:29:49 EDT
There is existing pulp bug for this issue : https://pulp.plan.io/issues/2754
Comment 4 Brad Buckingham 2017-09-22 15:12:38 EDT

*** This bug has been marked as a duplicate of bug 1450113 ***

Note You need to log in before you can comment on or make changes to this bug.