Bug 1461360 - pcs doesn't show full list of stonithd-implemented attributes
pcs doesn't show full list of stonithd-implemented attributes
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcs (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomas Jelinek
cluster-qe@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 05:53 EDT by Klaus Wenninger
Modified: 2017-06-14 08:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-14 08:35:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaus Wenninger 2017-06-14 05:53:31 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. pcs stonith describe fence_sbd (or any other)
2.
3.

Actual results:

Properly shows the attributes implemented in the resource agend itself.
Shows a couple of attributes that are actually implemented in stonithd, are handled there and aren't passed over to the fence-agent (e.g. pcmk_host_map).
But this seems to be a static list and doesn't show all attributes implemented.

Expected results:

Be consistent.
Either Show all attributes that are implemented by stonithd.
Or alternatively it would be possible to remove the stonithd-implemented attributes from what is shown when asked for the description of a distinct fence-agent and show a full list upon 'pcs stonith describe stonithd'.

Additional info:

'/usr/libexec/pacemaker/stonithd metadata' gives the full list of stonithd-implemented attributes in the usual metadata-xml-format.
Comment 2 Tomas Jelinek 2017-06-14 07:51:00 EDT
This is a requested pcs feature.

By default, pcs only displays parameters which are not marked as advanced so the user is not overwhelmed by the huge number of options. Full list of parameters is displayed when --full is specified:
pcs stonith describe fence_sbd --full


> But this seems to be a static list

Yes, it is. The list is implemented in stonithd and its metadata: those options whose description starts with "Advanced use only" are considered advanced by pcs and are only displayed when --full is specified.
Comment 3 Klaus Wenninger 2017-06-14 08:35:41 EDT
(In reply to Tomas Jelinek from comment #2)
> This is a requested pcs feature.
> 
> By default, pcs only displays parameters which are not marked as advanced so
> the user is not overwhelmed by the huge number of options. Full list of
> parameters is displayed when --full is specified:
> pcs stonith describe fence_sbd --full

Man-page shows it - please accept my apologies ;-)

> 
> 
> > But this seems to be a static list
> 
> Yes, it is. The list is implemented in stonithd and its metadata: those
> options whose description starts with "Advanced use only" are considered
> advanced by pcs and are only displayed when --full is specified.

Note You need to log in before you can comment on or make changes to this bug.