Bug 1461397 - hammers returns empty string instead of 0(zero) for no installable erratas for content host
hammers returns empty string instead of 0(zero) for no installable erratas fo...
Status: NEW
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer - Content (Show other bugs)
6.2.10
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 07:39 EDT by Jitendra Yejare
Modified: 2017-12-12 01:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jitendra Yejare 2017-06-14 07:39:50 EDT
Description of problem:
The number of installable erratas are displayed as ""(Empty String) post upgrade instead of 0(Zero). This is been observed only during upgrade from 6.1 to 6.2, But this is not the case during zStream upgrade(i.e 6.2 to 6.2). zStream uprade retains ) value during upgrade but not major version upgrades.


Version-Release number of selected component (if applicable):
Satellite 6.2.10

How reproducible:
Always

Steps to Reproduce:
1. Satellite 6.1 with content hosts having no installable errata
2. Upgrade Satellite 6.1 to 6.2

Actual results:
Post Upgrade, the instalable errata count in content host list via hammer returns ""(empty string) instead of zero(0).

Expected results:
Post Upgrade, the instalable errata count in content host list via hammer returns ""(empty string) instead of zero(0).

Additional info:
This observation is only for major versions upgrade and NOT with zStream versions.
Comment 1 Jitendra Yejare 2017-06-14 07:41:30 EDT
This is failing Post upgrade entity existance automation test due to Empty String returned instead of Zero.

Note You need to log in before you can comment on or make changes to this bug.