Bug 146143 - yum should do partial upgrades
Summary: yum should do partial upgrades
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 3
Hardware: noarch
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
: 147441 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-25 17:30 UTC by Orion Poplawski
Modified: 2014-01-21 22:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 19:23:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Orion Poplawski 2005-01-25 17:30:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041217

Description of problem:
For a while now, due to a bug the the FC3 repo, systems have not been
updated:

[root@cynosure pam.d]# yum -y update
Setting up Update Process
Setting up Repos
CoRA                      100% |=========================|  951 B    00:00
Reading repository metadata in from local files
CoRA      : ################################################## 1768/1768
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package grep.i386 0:2.5.1-31.4 set to be updated
---> Package dhclient.i386 7:3.0.1-30_FC3 set to be updated
---> Package gimp.i386 2:2.2.2-0.fc3.3 set to be updated
---> Package alsa-lib-devel.i386 0:1.0.6-7.FC3 set to be updated
---> Package kernel-utils.i386 1:2.4-13.1.49_FC3 set to be updated
---> Package tetex-dvips.i386 0:2.0.2-21.3 set to be updated
---> Package kernel-module-ntfs-2.6.10-1.737_FC3.i686
0:2.1.22-0.rr.4.3 set to be updated
---> Package pam.i386 0:0.77-66.2 set to be updated
---> Package vixie-cron.i386 1:4.1-20_FC3 set to be updated
---> Package gphoto2.i386 0:2.1.5-1.1 set to be updated
---> Package cups.i386 1:1.1.22-0.rc1.8.4 set to be updated
---> Package tetex-latex.i386 0:2.0.2-21.3 set to be updated
---> Package tetex-xdvi.i386 0:2.0.2-21.3 set to be updated
---> Package bind-libs.i386 20:9.2.4-8_FC3 set to be updated
---> Package libquicktime.i586 0:0.9.4-1.1.fc3.rf set to be updated
---> Package sysklogd.i386 0:1.4.1-26_FC3 set to be updated
---> Package selinux-policy-targeted.noarch 0:1.17.30-2.73 set to be
updated
---> Package cups-libs.i386 1:1.1.22-0.rc1.8.4 set to be updated
---> Package tetex-afm.i386 0:2.0.2-21.3 set to be updated
---> Package alsa-lib.i386 0:1.0.6-7.FC3 set to be updated
---> Package hal.i386 0:0.4.6-1.FC3 set to be updated
---> Package xpdf.i386 1:3.00-10.2 set to be updated
---> Package wireless-tools.i386 1:28-0.pre4.1.fc3 set to be updated
---> Package tetex-fonts.i386 0:2.0.2-21.3 set to be updated
---> Package bind-utils.i386 20:9.2.4-8_FC3 set to be updated
---> Package tetex.i386 0:2.0.2-21.3 set to be updated
--> Running transaction check
--> Processing Dependency: libiw.so.27 for package: kdenetwork
--> Finished Dependency Resolution
Error: Missing Dependency: libiw.so.27 is needed by package kdenetwork


It seems to me that the other packages that need updating should be
updated.  Problems with kdenetwork should not block the others from
being upgraded.

Version-Release number of selected component (if applicable):
yum-2.1.13

How reproducible:
Always

Steps to Reproduce:
1.  Try to keep system up to date automatically with yum with current
repo.
2.
3.
    

Actual Results:  No packages are updated

Expected Results:  Those packages without issues should be updated.

Additional info:

This is a feature request but it has security implications around
keeping systems up to date.

Comment 1 Rahul Sundaram 2005-06-19 03:10:26 UTC
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=147441 Seems to be related

Comment 2 Rahul Sundaram 2005-06-20 19:52:25 UTC
*** Bug 147441 has been marked as a duplicate of this bug. ***

Comment 3 Jeremy Katz 2005-09-21 19:23:44 UTC
The right thing to do here is to keep repositories consistent, especially for
official things like updates.  yum 2.4 has the option of dropping into the shell
to resolve these by turning some stuff off if you want

Comment 4 Christopher Beland 2009-03-08 18:50:04 UTC
Just a note for posterity, at least as of Fedora 9, yum does support the --skip-broken option, which I think does what the reporter is requesting.


Note You need to log in before you can comment on or make changes to this bug.