This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1461452 - [Satellite6] nested hostgroup non accessible when parent hostgroup changes organization
[Satellite6] nested hostgroup non accessible when parent hostgroup changes or...
Status: CLOSED DUPLICATE of bug 1461454
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Host Group (Show other bugs)
6.2.8
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 09:21 EDT by Stefan Nemeth
Modified: 2017-06-20 15:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-20 15:10:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Nemeth 2017-06-14 09:21:06 EDT
Description of problem:

Is it possible to nest host groups through organizations by administrator who is eligible to (select different organization HG from "parent" selection). Then broken host group appears to the organization specific administrator in HG list, which cannot be viewed or edited.

When accessing the nested organization error is displayed

"Host Group not found Please try to update your request" 

Version-Release number of selected component (if applicable):
satellite 6.2.9

How reproducible:
100%

Steps to Reproduce:
1.create 2 different organizations in satellite 6 (lab, test)
2.create 2 org admins (labadmin, testadmin)
3.as satellite admin create hostgroup testgroup belonging to both organizations
4.login as labadmin or testadmin and create a nested hostgroup 
5.log back as satellite admin and remove organizations or change to default organization of parent hostgroup
6.log back in as organziation admin

Actual results:

"Host Group not found Please try to update your request"

Expected results:

Do not allow to change organization or change organization for nested hostgroup as well

Additional info:
Comment 1 Brad Buckingham 2017-06-20 15:10:16 EDT

*** This bug has been marked as a duplicate of bug 1461454 ***

Note You need to log in before you can comment on or make changes to this bug.