Bug 1461472 - Unable to list available pools given a large manifest
Unable to list available pools given a large manifest
Status: CLOSED CURRENTRELEASE
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
2.0
Unspecified Unspecified
high Severity urgent
: ---
: 2.0
Assigned To: William Poteat
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 10:14 EDT by Chris Snyder
Modified: 2017-07-26 15:22 EDT (History)
6 users (show)

See Also:
Fixed In Version: candlepin-2.0.39-1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-26 15:22:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github candlepin/candlepin/pull/1626 None None None 2017-06-29 09:08 EDT

  None (edit)
Comment 1 Michael Stead 2017-06-29 09:11:29 EDT
This issue was not due to the size of the manifest, but was due to importing a 2.0+ manifest into an older version of candlepin. The updated rules file was expecting data that was not being provided by the older candlepin.

The fix was to update the rules to check for the existence of the data instead of assuming it was there.

Note You need to log in before you can comment on or make changes to this bug.