Bug 1461473 - [RFE] Ability to apply roles to host groups
[RFE] Ability to apply roles to host groups
Status: CLOSED DUPLICATE of bug 1453061
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles (Show other bugs)
6.3.0
All Linux
low Severity low (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 10:19 EDT by Marc Richter
Modified: 2017-11-03 09:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-15 04:43:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Richter 2017-06-14 10:19:44 EDT
Description of problem:

From the customer:

This is the breakdown of the requirements coming from a user.

•       API that enables us to:
      o Create collections of hosts (hostgroups)
      o Add hosts to one or more groups
      o Create  collections of users (usergroups)
      o Add users to one or more groups
      o Create "profiles" (Containers that hold sets of permissions)
      o Add permission statements to the containers
      o Link between profiles and groups so we can grant/deny permissions
•       GUI in Sat6 to do all of the above

The request is to be able to apply role permissions to host groups based on users pulled from our CMDB through an API call to see what SME’s are part of the computer system environment.

Today Satellite can only apply roles based on Organization and Location.
Comment 1 Marek Hulan 2017-06-15 04:43:14 EDT
Thanks for the report. Profiles exist today and are called Roles. Satellite provides API for everything from the list except for tailoring the role for a given host group / host collection. That is already tracked under BZ 1453061. I'm closing this as a duplicate of it, please reopen or let me know if I misunderstood the request.

*** This bug has been marked as a duplicate of bug 1453061 ***

Note You need to log in before you can comment on or make changes to this bug.