This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1461491 - ceph 1.3 fails with package conflicts on RHEL 7.4
ceph 1.3 fails with package conflicts on RHEL 7.4
Status: NEW
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Distribution (Show other bugs)
1.3.3
Unspecified Unspecified
urgent Severity urgent
: rc
: 1.3.3
Assigned To: Boris Ranto
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 11:05 EDT by Mike Burns
Modified: 2017-09-21 19:15 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2017-06-14 11:05:12 EDT
Description of problem:
RHEL 7.4 includes ceph-common shipped in the base server repository.  This seems to be from ceph 2.0 and generates package conflicts when installing ceph 1.3 content.

Basically, the issue is that ceph-osd, ceph-mon, etc all require ceph which requires ceph-common, all of which are the same version.  This expands to the other ceph-common packages like librados2 and librbd1.  An example of this is below.

Note:  it's possible to yum install if there are *no* ceph packages pre-installed, but yum updates would fail because it would try to update the ceph-common packages.  

Example:

Error: Package: 1:python-rados-0.94.9-9.el7cp.x86_64 (rhos-9.0-director-ceph-1.3-mon-signed)
           Requires: librados2 = 1:0.94.9-9.el7cp
           Installed: 1:librados2-10.2.5-3.el7.x86_64 (@rhos-9.0-rhel-7-signed)
               librados2 = 1:10.2.5-3.el7

Note You need to log in before you can comment on or make changes to this bug.