Bug 1461508 - [Docs][Install] If custom partitioning is used, it should be documented that /usr cannot be in its own partition
[Docs][Install] If custom partitioning is used, it should be documented that ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
4.1.1
Unspecified Unspecified
urgent Severity high
: ovirt-4.1.3
: ---
Assigned To: Avital Pinnick
Tahlia Richardson
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 11:56 EDT by Gordon Watson
Modified: 2017-07-14 05:38 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 05:33:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Docs
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Watson 2017-06-14 11:56:27 EDT
Description of problem:

When using custom partitioning during RHVH installation, creating a separate partition for /usr will cause the installation to fail. It turns out that /usr should not be allocated in its own partition, and that this should be documented.

As such, the 'Advanced Installation' section of the RHV Installation Guide should be updated to document this limitation.

I would suggest according a note in the '6.2.1. Custom Partitioning' section.


Version-Release number of selected component (if applicable):

RHVH-4.1-20170523.1


How reproducible:

Every time.


Steps to Reproduce:

1. Perform RHVH installation. 
2. Select the custom partitioning option.
3. Include partition for /usr.

Actual results:


Expected results:


Additional info:
Comment 1 Yaniv Lavi 2017-06-20 03:21:58 EDT
Can you confirm this is a limitation? Anything to add to this?
Comment 2 Ryan Barry 2017-06-20 06:14:15 EDT
This is a definite limitation. /usr must be on an LV which is able to change versions along with RHVH (generally, leaving /usr on /)

Imagine that a user installs RHVH 4.0.7/7.3

The user then upgrades to RHVH 4.1/7.4

What state are /usr/lib[64], /usr/[s]bin, and other paths in? Probably they work with 7.4 library versions. But trying to roll back to 7.3 will result in broken linked library dependencies
Comment 3 Lucy Bopf 2017-06-28 03:40:32 EDT
Assigning to Avital for review.

Avital, we need to add a note as suggested in the Description, and include the reasoning from comment 2 ("/usr must be on an LV which is able to change versions along with RHVH (generally, leaving /usr on /)").

Note You need to log in before you can comment on or make changes to this bug.