Bug 1461548 - No scrollbar on Service Catalog in CloudForms Self-Service UI
No scrollbar on Service Catalog in CloudForms Self-Service UI
Status: CLOSED WORKSFORME
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - Service (Show other bugs)
5.8.0
Unspecified Unspecified
low Severity low
: GA
: cfme-future
Assigned To: Chris Hale
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 14:38 EDT by Jerome Marc
Modified: 2017-06-17 11:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-16 11:19:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerome Marc 2017-06-14 14:38:49 EDT
Description of problem:
The service catalog view in the Self-Service UI does not provide a scollbar to the end-user, nor the ability to scoll with the mouse. This means only the first service items can be ordered from the SSUI.

Version-Release number of selected component (if applicable):
5.8.0.17.20170525183055_6317a22

How reproducible:
Always

Steps to Reproduce:
1. Login in SSUI (having Service Items setup in the Service Catalog for more than your screen resolution can show on the page)
2. Navigate to Service Catalog
3. Try to access a Service Item which is not in the view (requiring scrolling)

Actual results:
Impossible to scroll

Expected results:
User should be able to see all Service Items

Additional info:
The only workaround is to limit the number of items per page to 5 and use the page next button.
Comment 2 Chris Kacerguis 2017-06-14 17:32:26 EDT
A Pivotal Tracker story has been created for this Bug: https://www.pivotaltracker.com/story/show/147233983
Comment 3 Chris Hale 2017-06-15 10:21:31 EDT
Which web browser, version and operating system are you testing this issue on?   I tested this in Google Chrome and scrolling works on Service catalog explorer page
Comment 4 Chris Kacerguis 2017-06-15 10:43:17 EDT
Chris Hale added a comment in Pivotal Tracker:   
   
Awaiting feedback on how to reproduce issue on which browser and platform
Comment 5 Chris Kacerguis 2017-06-15 15:36:59 EDT
Setting to low per the Triage call today.
Comment 6 Chris Kacerguis 2017-06-15 15:43:08 EDT
I am unable to reproduce this issue with:

MacOS - Safari 10.1.1 (12603.2.4)
Windows 10 - Edge 40.15063.0.0
Windows 10 - Chrome 58.0.3029.110
Windows 10 - Chrome 59.3071.104
Comment 7 Chris Kacerguis 2017-06-16 11:19:42 EDT
This was also tested on Firefox in Windows by Allen W, he was unable to reproduce the issue.  Going to mark this CLOSED, WORKSFORME.  Please feel free to reopen if you can provide an appliance that can replicate this issue and we'll be happy to take a look.
Comment 8 Chris Kacerguis 2017-06-17 11:28:56 EDT
Chris Kacerguis deleted the linked story in Pivotal Tracker

Note You need to log in before you can comment on or make changes to this bug.