Bug 1461632 - Kernel 4.11 panics upon launching GNOME - nouveau problem.
Kernel 4.11 panics upon launching GNOME - nouveau problem.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
25
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-14 22:20 EDT by rosenp
Modified: 2017-08-16 14:55 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-16 14:55:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sudo journalctl -b -1 | grep nouveau (11.74 KB, text/plain)
2017-06-14 22:20 EDT, rosenp
no flags Details

  None (edit)
Description rosenp 2017-06-14 22:20:16 EDT
Created attachment 1287872 [details]
sudo journalctl -b -1 | grep nouveau

Description of problem:
ernel 4.11 panics upon launching GNOME. Nouveau is crashing.

Version-Release number of selected component (if applicable):
4.11

How reproducible:
Always

Steps to Reproduce:
1.Boot

Actual results:
Can't see GNOME login

Expected results:
Can see GNOME login

Additional info:

Hardware is a laptop with a GTX 980 (not M). This is worrying since if I update my kernel, 4.10.17 gets deleted which allows me to use Fedora.

Here's a relevant journald log:
Comment 1 Laura Abbott 2017-06-15 10:50:04 EDT
https://bodhi.fedoraproject.org/updates/FEDORA-2017-c283e18644 contains a fix for a nouveau problem. Please test 4.11.5.
Comment 2 rosenp 2017-06-17 13:41:29 EDT
Same issue.

It comes from a bunch of SecureBoot changes done for 4.11. Unfortunately the Nvidia employee that worked on this is no longer there.

It also does not help that my GPU is not a reference design. Either I have to figure out how to stay on an old kernel or install the proprietary drivers.
Comment 3 rosenp 2017-06-20 18:51:51 EDT
I discovered a commit by the former nvidia employee which fixes my issue. It's queued for 4.12 and needs to be backported to 4.11. The commit is here: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/drivers/gpu/drm/nouveau?h=v4.12-rc6&id=913b97f94478db1c93cc5a1f07fa03ee4e2d5f8b
Comment 4 rosenp 2017-06-20 19:46:50 EDT
(In reply to rosenp from comment #3)
> I discovered a commit by the former nvidia employee which fixes my issue.
> It's queued for 4.12 and needs to be backported to 4.11. The commit is here:
> https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/
> drivers/gpu/drm/nouveau?h=v4.12-
> rc6&id=913b97f94478db1c93cc5a1f07fa03ee4e2d5f8b

correction. that one and the previous two.
Comment 5 rosenp 2017-08-16 14:55:11 EDT
4.12 has the fix. closing.

Note You need to log in before you can comment on or make changes to this bug.