Bug 146167 - no longer creates ~/.gnupg when first run
Summary: no longer creates ~/.gnupg when first run
Status: CLOSED DUPLICATE of bug 139209
Alias: None
Product: Fedora
Classification: Fedora
Component: gnupg (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-25 19:08 UTC by Dax Kelson
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 20:12:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dax Kelson 2005-01-25 19:08:26 UTC
Description of problem:

I don't know if this intentional (SELinux??) or not, but there is a
behavior change with gnupg v1.2.6 shipped with FC3 vs gnupg v1.2.1 FC2
and ealier.

Before when invoking "gnupg --gen-key" it would automtically create
~/.gnupg. In fact, it would tell you so:

$ gpg --gen-key
gpg (GnuPG) 1.2.1; Copyright (C) 2002 Free Software Foundation, Inc.
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details.

gpg: WARNING: using insecure memory!
gpg: please see http://www.gnupg.org/faq.html for more information
gpg: /home/guru/.gnupg: directory created

       ^^^^^^^^^^^^^^^^^

Now with v1.2.6 shipped with FC3, it doesn't create the directory, and
instead you get lots of nasy error messages.

$ gpg --gen-key
gpg (GnuPG) 1.2.6; Copyright (C) 2004 Free Software Foundation, Inc.
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details.

gpg: failed to create temporary file
`/home/guru/.gnupg/.#lk0xf7005868.station3.example.com.17720': No such
file or directory
gpg: keyblock resource `/home/guru/.gnupg/secring.gpg': general error
gpg: failed to create temporary file
`/home/guru/.gnupg/.#lk0xf7005cc0.station3.example.com.17720': No such
file or directory
gpg: keyblock resource `/home/guru/.gnupg/pubring.gpg': general error
Please select what kind of key you want:

[snip lots of questions asked]

gpg: no writable public keyring found: eof
Key generation failed: eof
gpg: can't create `/home/guru/.gnupg/random_seed': No such file or
directory

Comment 1 Peter Bieringer 2005-03-30 12:09:31 UTC
Same happen to me on RHEL4, see also:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=150935

Comment 2 Nalin Dahyabhai 2005-07-29 20:12:47 UTC

*** This bug has been marked as a duplicate of 139209 ***


Note You need to log in before you can comment on or make changes to this bug.