Bug 1461682 - cann't show vnc server status in monitor via "info vnc" when connect to a listening vnc with "reverse"
cann't show vnc server status in monitor via "info vnc" when connect to a lis...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.4
All Linux
low Severity low
: rc
: ---
Assigned To: Marc-Andre Lureau
Virtualization Bugs
:
Depends On: 813267
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 03:36 EDT by yilzhang
Modified: 2017-07-30 23:24 EDT (History)
25 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 813267
Environment:
Last Closed: 2017-06-20 09:36:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Marc-Andre Lureau 2017-06-18 16:50:18 EDT
Did anything changed since Luiz comment? Is HMP supported in RHEL? I agree this could be a bug upstream if it's not supported and there is no real customer issue.
Comment 3 yilzhang 2017-06-19 05:36:22 EDT
Boot up guest and guest(running as VNC server) can successfully connect to the listening VNC client, this function now works well.

And since HMP is supported in RHEL7, so it's expected that after guest boot up, "info vnc" should display correct vnc server status.

Is it like this for RHEL7?
Comment 4 yilzhang 2017-06-19 05:57:41 EDT
(In reply to Marc-Andre Lureau from comment #2)
> Did anything changed since Luiz comment? Is HMP supported in RHEL? I agree
> this could be a bug upstream if it's not supported and there is no real
> customer issue.

I don't know much about this feature, I've added one needinfo to Luiz.
You may also ask him for more information. Thanks.
Comment 5 Luiz Capitulino 2017-06-19 09:09:24 EDT
Markus is the right person to ask.
Comment 6 Ademar Reis 2017-06-19 10:20:32 EDT
(In reply to yilzhang from comment #3)
> Boot up guest and guest(running as VNC server) can successfully connect to
> the listening VNC client, this function now works well.
> 
> And since HMP is supported in RHEL7, so it's expected that after guest boot
> up, "info vnc" should display correct vnc server status.
> 

HMP is *not* supported in RHEL7. We only support QEMU usage through libvirt (with the exception of documented usage of tools like qemu-img).
Comment 7 Markus Armbruster 2017-06-19 12:00:25 EDT
Clearing needinfo.  If you have further questions, please don't hesitate to ask.
Comment 8 yilzhang 2017-06-19 23:35:40 EDT
Thanks Ademar for your clarification.

Since this bug is in Low priority, what is your suggestion or next plan about this bug?
Comment 9 Ademar Reis 2017-06-20 09:36:47 EDT
I'm closing it as wontfix again. Fixing it upstream and getting it in a future release of RHEL is a "nice-to-have", not a requirement.
Comment 10 Dr. David Alan Gilbert 2017-07-05 10:48:42 EDT
I've posted an upstream patch for this:

https://lists.nongnu.org/archive/html/qemu-devel/2017-07/msg01039.html
[PATCH] hmp: Update info vnc


I don't think we'll backport this, so it should turn up eventually when we rebase.

Note You need to log in before you can comment on or make changes to this bug.