Bug 1461718 - Process %CPU usage shown erroneously
Process %CPU usage shown erroneously
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: procps (Show other bugs)
6.0
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jan Rybar
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 05:25 EDT by khazim.bubben
Modified: 2017-12-06 07:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 07:26:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description khazim.bubben 2017-06-15 05:25:50 EDT
Description of problem:
One CPU can be seen as running at ~12-15% in htop.
Even so, no CPU% is shown to be used by any process.

Also, the ps output tells us that the process /usr/sbin/modgudd have been running for aproximately 295 years.
root@krut-gw-6:~# ps -ef | grep modgud
root      1204     1 99  2015 ?        107947-04:13:10 /usr/sbin/modgudd --pidfile=/var/run/modgudd.pid --socketfile=/var/run/modgudd.sock --script-directory=/etc/modgud --configuration=sqlite3:/etc/modgud/configuration.sqlite3

Which should not be possible since the uptime of the host is:
root@krut-gw-6:~# uptime
 10:34:04 up 860 days,  4:30,  2 users,  load average: 0.00, 0.02, 0.00

Version-Release number of selected component (if applicable):


How reproducible:
Seems to happen when a process have been running for a long time.

Steps to Reproduce:
1. Run process for a long time.

Actual results:
Running time of process is longer than the uptime of the system.

Expected results:
Running time of process should not be longer than the uptime of the system.

Additional info:
Comment 2 Ondrej Vasik 2017-06-15 08:30:07 EDT
Reassigning to more suitable component.
Comment 3 Jan Rybar 2017-09-22 11:31:00 EDT
htop is not a part of procps, but with the second issue with wrong uptime values, please check the length of file /proc/stat when you encounter the problem.
If it's excessively long then showing wrong values for STIME is a known issue and is to be fixed.

Please note that RHEL6 has entered Phase 3, which means only critical issues shall be fixed.
Comment 4 khazim.bubben 2017-11-27 08:56:13 EST
I do not have access to that computer anymore, but it does sound that our problems were due to the mentioned bug.
Comment 5 Jan Kurik 2017-12-06 07:26:07 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.