Bug 1461782 - [RFE] Make katello-certs-check return absolute paths
[RFE] Make katello-certs-check return absolute paths
Status: CLOSED DUPLICATE of bug 1358935
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Other (Show other bugs)
6.2.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 06:23 EDT by Tapomoy Bhowmik
Modified: 2017-06-26 09:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-20 15:38:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tapomoy Bhowmik 2017-06-15 06:23:21 EDT
Description of problem: The katello-certs-check returns the command for possible operations with satellite-installer after verifying the provided files are correct.

Problem is if the parameters are relative to the position of the execution, say 

-----------
# katello-certs-check -c  xxx.example.com.cer -r xxx.example.com.csr -k  xxx.example.com.key -b  /etc/pki/ca-trust/source/anchors/ISSUECATID_bundle_2016-2030.cer
----------

It returns the satellite-installer command with the same relative paths which, as the installer passed the parameters verbatim to the satellite-answers file, breaks a number of things.

-----------------
..............
To install the Satellite main server with the custom certificates, run:

    satellite-installer --scenario satellite\
                        --certs-server-cert "xxx.example.com.cer"\
                        --certs-server-cert-req "xxx.example.com.csr"\
                        --certs-server-key "xxx.example.com.key"\
                        --certs-server-ca-cert "/etc/pki/ca-trust/source/anchors/ISSUECATID_bundle_2016-2030.cer"
...............
------------------

Proposed change is to katello-certs-check to calculate the real path of the files and add them to the satellite-installer commands so the admin doesn't hit a problem later.


Version-Release number of selected component (if applicable):


How reproducible: N/A


Steps to Reproduce: N/A


Actual results: It returns the satellite-installer command with the same relative paths which, as the installer passed the parameters verbatim to the satellite-answers file, breaks a number of things.


Expected results: katello-certs-check to calculate the real path of the files and add them to the satellite-installer commands so the admin doesn't hit a problem later.


Additional info:
Comment 1 jcallaha 2017-06-20 15:38:44 EDT
This is a duplicate and fixed in 6.3.

*** This bug has been marked as a duplicate of bug 1358935 ***

Note You need to log in before you can comment on or make changes to this bug.