Bug 1461812 - RHEL Atomic 7.4 Missing Dnsmasq
RHEL Atomic 7.4 Missing Dnsmasq
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhel-server-atomic (Show other bugs)
7.4
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Colin Walters
atomic-bugs@redhat.com
aos-scalability-36
: Extras
: 1463767 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 07:35 EDT by Sebastian Jug
Modified: 2018-02-12 10:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-12 10:37:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1449321 None None None 2017-06-15 10:22 EDT

  None (edit)
Description Sebastian Jug 2017-06-15 07:35:10 EDT
Description of problem:
All RHEL Atomic trees after 'Atomic-7.4-20170519.0' (including latest-7.4) do not have dnsmasq. This is a blocking issue for testing OpenShift as the installer assumes that dnsmasq is present for the Atomic install.


Version-Release number of selected component (if applicable):
Atomic-7.4-20170526.0 to latest-7.4

How reproducible:
100%

Steps to Reproduce:
1. Download last created image (rhel-atomic-cloud-7.4.0-3.x86_64.qcow2) from May 26 tree.
2. Start VM using image.
3. Inspect VM to check for function and presence of dnsmasq.

Actual results:
Dnsmasq is missing.

Expected results:
Dnsmasq should be installed and working.

Additional info:
Micah Abbott suggested workaround in the meantime:
1.  Find a build of 'dnsmasq' in brew and download it to your Atomic Host
2.  On the Atomic Host, use 'ostree admin unlock --hotfix' to 'unlock' your host
3.  Install the 'dnsmasq' package via 'rpm' as usual
Comment 2 Sebastian Jug 2017-06-15 07:36:18 EDT
Alternatively one can also download the current prod image of 7.3.5-7 and upgrade to the latest-7.4 repo and see the same issue.
Comment 3 Colin Walters 2017-06-15 10:22:09 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=1449321
Comment 4 Alex Jia 2017-06-15 10:25:38 EDT
BTW, the dnsmasq package exists in version 7.3.5-1 and 7.3.6.
Comment 5 Sebastian Jug 2017-06-15 10:41:10 EDT
Yes, dnsmasq did exist in all 7.3.x that we have tested.
Comment 6 Colin Walters 2017-06-16 16:43:47 EDT
https://code.engineering.redhat.com/gerrit/109306
Comment 7 Scott Dodson 2017-06-21 13:31:39 EDT
*** Bug 1463767 has been marked as a duplicate of this bug. ***
Comment 9 Steve Milner 2018-02-12 10:37:58 EST
This should be fixed in 7.4+.

Note You need to log in before you can comment on or make changes to this bug.