Bug 146189 - usb-storage can not be loaded into kernel
Summary: usb-storage can not be loaded into kernel
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-25 21:04 UTC by Brian Millett
Modified: 2015-01-04 22:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-26 18:51:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Millett 2005-01-25 21:04:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
usb flashdrive is not recognized by the kernel.  usb-storage module
can not load.  Kernel messages are:

Jan 25 11:52:37 localhost kernel: usb 2-1: new full speed USB device
using uhci_hcd and address 2
Jan 25 11:52:39 localhost modprobe: WARNING: Error inserting scsi_mod
(/lib/modules/2.6.10-1.1109_FC4/kernel/drivers/scsi/scsi_mod.ko):
Unknown symbol in module, or unknown parameter (see dmesg)
Jan 25 11:52:39 localhost modprobe: FATAL: Error inserting usb_storage
(/lib/modules/2.6.10-1.1109_FC4/kernel/drivers/usb/storage/usb-storage.ko):
Unknown symbol in module, or unknown parameter (see dmesg)
Jan 25 11:52:39 localhost kernel: scsi_mod: Unknown parameter `'
Jan 25 11:52:39 localhost kernel: usb_storage: Unknown symbol
scsi_report_device_reset
Jan 25 11:52:39 localhost kernel: usb_storage: Unknown symbol
scsi_remove_host
Jan 25 11:52:39 localhost kernel: usb_storage: Unknown symbol
scsi_host_put
Jan 25 11:52:39 localhost kernel: usb_storage: Unknown symbol
scsi_scan_host
Jan 25 11:52:39 localhost kernel: usb_storage: Unknown symbol
scsi_add_host
Jan 25 11:52:39 localhost kernel: usb_storage: Unknown symbol
scsi_host_alloc
Jan 25 11:52:39 localhost usb.agent[4315]: ... can't load module
usb-storage
Jan 25 11:52:39 localhost usb.agent[4315]: missing kernel or user mode
driver usb-storage
Jan 25 11:52:39 localhost modprobe: WARNING: Error inserting scsi_mod
(/lib/modules/2.6.10-1.1109_FC4/kernel/drivers/scsi/scsi_mod.ko):
Unknown symbol in module, or unknown parameter (see dmesg)
Jan 25 11:52:39 localhost kernel: scsi_mod: Unknown parameter `'
Jan 25 11:52:39 localhost usb.agent[4315]: ... can't load module
usb-storage
Jan 25 11:52:39 localhost kernel: usb_storage: Unknown symbol
scsi_report_device_reset
Jan 25 11:52:39 localhost usb.agent[4315]: missing kernel or user mode
driver usb-storage
Jan 25 11:52:39 localhost kernel: usb_storage: Unknown symbol
scsi_remove_host
Jan 25 11:52:40 localhost kernel: usb_storage: Unknown symbol
scsi_host_put
Jan 25 11:52:40 localhost kernel: usb_storage: Unknown symbol
scsi_scan_host
Jan 25 11:52:40 localhost kernel: usb_storage: Unknown symbol
scsi_add_host
Jan 25 11:52:40 localhost kernel: usb_storage: Unknown symbol
scsi_host_alloc
Jan 25 11:57:57 localhost kernel: usb 2-1: USB disconnect, address 2


Version-Release number of selected component (if applicable):
udev-050-1

How reproducible:
Always

Steps to Reproduce:
1. upgrade rawhide
2. reboot
3. insert usb flashdrive

    

Actual Results:  nothing showed.  see description above

Expected Results:  usb recognized and mounted

Additional info:

if I modprobe as follows, then all works fine:
[bpm]$ modprobe usb-ohci
[bpm]$ modprobe uhci-hcd
[bpm]$ modprobe ehci-hcd
[bpm]$ modprobe scsi-mod
[bpm]$ modprobe usb-storage

Comment 1 Harald Hoyer 2005-01-26 11:40:07 UTC
and why is this an udev issue???????????????????????

Comment 2 Brian Millett 2005-01-26 16:10:04 UTC
uhm, because I could not figure out what issue it was, so I asked on
the test list and jef said "udev".  Kind of lame, but it was the best
guess I had.

Comment 3 Brian Millett 2005-01-26 18:51:46 UTC
Ok, the wizzards did it again.  As of 01/26/05 rawhide upgrade, this
is no longer a problem.

Thanks to who ever fixed the problem.


Note You need to log in before you can comment on or make changes to this bug.