Bug 1461979 - gnuplot wxWidgets
gnuplot wxWidgets
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnuplot (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Frantisek Kluknavsky
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-15 15:20 EDT by D. E. Evans
Modified: 2017-07-11 09:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-11 09:59:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description D. E. Evans 2017-06-15 15:20:15 EDT
#761260 disables wxWidgets in gnuplot for RHEL. I'm restricted from viewing this ticket, but if I were to wager a guess, it was disabled due to an incompatibility with GTK in 2012. It is enabled for Fedora, however, and a test build reenabling it in the spec file is successful.

Perhaps it was an oversight to restrict this in RHEL 7?

I'd like to have wxWidgets support in gnuplot restored. We have a research group that uses this functionality, but has to use Fedora for it instead of RHEL, which is giving us some headaches.
Comment 2 Frantisek Kluknavsky 2017-06-19 10:14:46 EDT
#761260 does not explain much. #564090 explains that we never shipped wxGTK and we do not want to introduce it in RHEL6.

As far as I know, in RHEL7, we are still not shipping wxGTK. Please, correct me if I am wrong. I am sorry if this is my oversight but I am confused. Where did you get wxWidgets to build gnuplot?
Comment 3 D. E. Evans 2017-06-27 17:33:00 EDT
(In reply to Frantisek Kluknavsky from comment #2)
> As far as I know, in RHEL7, we are still not shipping wxGTK. Please, correct
> me if I am wrong.

This is correct. The problem is why not? The spec file has a conditional, enabling this for Fedora, but not for Red Hat.

> I am sorry if this is my oversight but I am confused.
> Where did you get wxWidgets to build gnuplot?

Essentially, I removed the spec file conditional and rebuilt the package.
Comment 4 Frantisek Kluknavsky 2017-06-30 10:06:09 EDT
A misunderstanding between us. English is not my native language, I will try again and differently.

When I try `ldd $(which gnuplot-wx)` on Fedora, I can see a bunch of wxwidgets-related libraries like:
	libwx_gtk2u_richtext-2.8.so.0 => /lib64/libwx_gtk2u_richtext-2.8.so.0 (0x00007ff353331000)
	libwx_gtk2u_aui-2.8.so.0 => /lib64/libwx_gtk2u_aui-2.8.so.0 (0x00007ff3530c6000)
	libwx_gtk2u_xrc-2.8.so.0 => /lib64/libwx_gtk2u_xrc-2.8.so.0 (0x00007ff352e1c000)
...

The same experiment on rhel - those libraries are not there.

When you remove the condition disabling wxwidgets on rhel, are you sure you actually get a working wx terminal?

Can you please run ldd <your_build_of_gnuplot> to see which libwx* libraries are used? Where are those libraries from?
Comment 5 D. E. Evans 2017-07-05 10:41:27 EDT
This is the equivalent snippet from my build:

        libwx_gtk2u_richtext-2.8.so.0 => /lib64/libwx_gtk2u_richtext-2.8.so.0 (0x00007f3650bac000)
        libwx_gtk2u_aui-2.8.so.0 => /lib64/libwx_gtk2u_aui-2.8.so.0 (0x00007f365093e000)
        libwx_gtk2u_xrc-2.8.so.0 => /lib64/libwx_gtk2u_xrc-2.8.so.0 (0x00007f36506a4000)

Looking closer, it appears I'm using the wxGTK packages from EPEL. Since RHEL doesn't include those libraries, I see now why the source RPM does not include it for building. I should have looked more carefully at that.

However, my point still stands: a build that is different in Fedora from EPEL causes confusion, and a disparity of development implementation. I find it odd that Fedora is using the gtk2 not gtk3 version, but I'm not familiar enough with the library's status.
Comment 6 Frantisek Kluknavsky 2017-07-11 09:59:11 EDT
Your point makes sense but as an engineer, I am not in a position to decide to start packaging wxGTK in RHEL and maintaining it forever. You need to go through proper support channels and persuade Red Hat's management with your business case. I can not help you until then.

Note You need to log in before you can comment on or make changes to this bug.