Bug 146200 - x86_64 RHE3 internal error: segmentation fault when compiling ada with gcc
x86_64 RHE3 internal error: segmentation fault when compiling ada with gcc
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-25 17:26 EST by Jack Pogue
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-26 12:15:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Pogue 2005-01-25 17:26:14 EST
Description of problem:
Compiling a simple ada "hello world" results in error...

+========================GNAT BUG DETECTED========================+
| 3.2.3 20030502 (3.2.3-13) (x86_64-redhat-linux-gnu) GCC error:  |
| internal error: Segmentation fault                              |
| No source file position information available                   |
| Please submit a bug report, see http://gcc.gnu.org/bugs.html    |
| Include the entire contents of this bug box in the report.      |
| Include the exact gcc or gnatmake command that you entered.     |
| Also include sources listed below in gnatchop format            |
| (concatenated together with no headers between files).          |
+=================================================================+

Please include these source files with error report

hello.adb

compilation abandoned

-----------------------------

I removed and recompiled gcc-gnat and the error remains.
The hello.adb file looks like....

with Ada.Text_IO; use Ada.Text_IO; procedure Hello is begin Put_Line 
("Hello WORLD!"); end Hello;

and this was compiled using

gcc -c hello.adb


lastly, I already sent the bug report to gcc bugzilla and they said 
to send the bug report to redhat.


Version-Release number of selected component (if applicable):
3.2.3-20  (although the error output says 3.2.3-13)

How reproducible:
Every time

Steps to Reproduce:
1.Install/compile default gcc-gnat
2.Create the hello.adb file shown above
3.type gcc -c hello.adb
  
Actual results:
+========================GNAT BUG DETECTED========================+
| 3.2.3 20030502 (3.2.3-13) (x86_64-redhat-linux-gnu) GCC error:  |
| internal error: Segmentation fault                              |
| No source file position information available                   |
| Please submit a bug report, see http://gcc.gnu.org/bugs.html    |
| Include the entire contents of this bug box in the report.      |
| Include the exact gcc or gnatmake command that you entered.     |
| Also include sources listed below in gnatchop format            |
| (concatenated together with no headers between files).          |
+=================================================================+

Please include these source files with error report

hello.adb

compilation abandoned


Expected results:
The file should have compiled

Additional info:
Comment 1 Jakub Jelinek 2005-01-26 05:17:26 EST
What kernel are you using?
The early RHEL3 kernels did not grok PT_GNU_STACK markings properly, so you
needed booting with noexec=off noexec32=off.  This got fixed either in U2, or in
U3, not sure ATM.
Comment 2 Jack Pogue 2005-01-26 12:03:59 EST
Kernel: 2.4.21-4.ELsmp



Comment 3 Jakub Jelinek 2005-01-26 12:15:00 EST
Yeah, that's too old.
So you either need to reboot with noexec=off noexec32=off kernel command line
arguments, or up2date the box to U4 including kernel and reboot into that kernel.

Note You need to log in before you can comment on or make changes to this bug.