Bug 1462085 - [Docs][Admin] Improve Virtio-SCSI Documentation
[Docs][Admin] Improve Virtio-SCSI Documentation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
4.1.2
x86_64 Linux
high Severity high
: ovirt-4.1.4
: ---
Assigned To: Avital Pinnick
Megan Lewis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-16 03:16 EDT by Germano Veit Michel
Modified: 2017-08-08 03:26 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-08 03:26:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Docs
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Article) 521613 None None None 2017-06-20 03:35 EDT

  None (edit)
Description Germano Veit Michel 2017-06-16 03:16:28 EDT
Description of problem:

[1] is a section about Virtual Machine Disks. 

a) In 11.6.2, in tables 11.2, 11.3 and 11.4 the "interface" row lacks a reference to Virtio-SCSI.

b) It's missing that for the Virtio-SCSI option to show up, we need to set  VM-> Edit->Resource Allocation-> Virtio-SCSI Enable, otherwise it doesn't show up.

c) It's missing a better description in the initial sections (11.1 or 11.2?) about the differences between IDE, Virtio and Virtio-SCSI (number of supported disks, performance, discard, passthrough...) and a general recommendations. 

d) If we add the above (c) in separate section, then there is no need to repeat 3 times (table 11.2, 11.3 and 11.4) that Windows does not ship with Virtio and the drivers needs to be installed and also that and Virtio is included in RHEL5+ or higher.

[1] https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.1/html-single/administration_guide/#chap-Virtual_Machine_Disks
Comment 2 Yaniv Lavi 2017-06-20 03:30:37 EDT
(In reply to Germano Veit Michel from comment #0)
> Description of problem:
> 
> [1] is a section about Virtual Machine Disks. 
> 
> a) In 11.6.2, in tables 11.2, 11.3 and 11.4 the "interface" row lacks a
> reference to Virtio-SCSI.
> 
> b) It's missing that for the Virtio-SCSI option to show up, we need to set 
> VM-> Edit->Resource Allocation-> Virtio-SCSI Enable, otherwise it doesn't
> show up.

We should fix this, it's an easy fix.

> 
> c) It's missing a better description in the initial sections (11.1 or 11.2?)
> about the differences between IDE, Virtio and Virtio-SCSI (number of
> supported disks, performance, discard, passthrough...) and a general
> recommendations. 
> 
> d) If we add the above (c) in separate section, then there is no need to
> repeat 3 times (table 11.2, 11.3 and 11.4) that Windows does not ship with
> Virtio and the drivers needs to be installed and also that and Virtio is
> included in RHEL5+ or higher.

We should either open an RHEL bug to provide this info or link to it if it exists.

> 
> [1]
> https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.1/
> html-single/administration_guide/#chap-Virtual_Machine_Disks
Comment 4 Lucy Bopf 2017-07-28 04:25:19 EDT
Assigning to Avital for review.

Avital, a) and b) should be simple enough to fix. For c) and d), I'd suggest looking for RHEL documentation that describes those different interface types, since they are not specific to RHV.
Comment 13 Avital Pinnick 2017-08-01 03:45:39 EDT
The scope of this fix has expanded. The documentation, as it stands, conflated two procedures, creating floating virtual disks ("Creating Virtual Floating Disks") and creating attached virtual disks ("Explanation of Settings in the New Virtual Disk Window"), that is, non-floating virtual disks.

I think that a UI bug should be submitted for the Administration Portal. It does not make sense to have two windows, one for creating floating virtual disks and one for creating attached virtual disks, to both have the same name, "New Virtual Disk." This was a contributing factor to the confusion.

Germano and I have discussed the differences between virtio and virtio-scsi, so that section will be expanded.

Note You need to log in before you can comment on or make changes to this bug.