Bug 1462100 - LibreOffice QuickStarter is no longer available in system tray
Summary: LibreOffice QuickStarter is no longer available in system tray
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-16 07:50 UTC by Pavel Kovalenko
Modified: 2017-06-17 12:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-16 08:17:01 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1110101 0 unspecified CLOSED [kde] LibreOffice QuickStarter is no longer available in system tray after installing libreoffice-kde 2021-02-22 00:41:40 UTC

Description Pavel Kovalenko 2017-06-16 07:50:26 UTC
Description of problem:
libreoffice: unavailable quickstarter

Version-Release number of selected component (if applicable):
LibreOffice Version: 5.2.7.2
ID: 5.2.7.2-3.fc25

How reproducible:


Steps to Reproduce:
1. Install libreoffice (sudo dnf install libreoffice-writer)
2. Start libreoffice (libreoffice --writer)
3. Try to enable QuickStarter (Tools > Options > Memory) 

Actual results:
QuickStarter no longer available in system tray. No such option avaible
Without quickstarter LibreOffice opens files very slowly.
With all enabled tweaks -preload, JavaDisabled, 64Gb of memory - 2 seconds.


Expected results:
QuickStarter should be available in system tray:
https://ask.libreoffice.org/upfiles/14915774457829115.png
With quickstarter LibreOffice opens files instantly.

Additional info:
1. This option is avaible in official docs:
https://help.libreoffice.org/index.php?title=Common/Memory&Version=5.2

2. In Gentoo this was fixed
https://bugs.gentoo.org/show_bug.cgi?id=561842

3. The cost of the lack of options per employee:
2 seconds * 50 times * 22 working days = 36 minutes
0.6 hours * 3$ per hour * 12 months = $ 21 per year

Comment 1 Caolan McNamara 2017-06-16 08:17:01 UTC
The systray thing is gtk2 only while we've moved on to gtk3 by default. The full systray set of gtk apis (https://developer.gnome.org/gtk3/stable/GtkStatusIcon.html) fot the systray have been deprecated and the systray concept is deprecated since GNOME3 (https://wiki.gnome.org/Design/OS/MessageTray/Compatibility) so its not practical to reimplement the systray for gtk3. Retaining it for gtk2 only doesn't gain us much.

Comment 2 Pavel Kovalenko 2017-06-17 12:40:57 UTC
I create bug report on LibreOffice community site:
https://bugs.documentfoundation.org/show_bug.cgi?id=108565

It must be fixed before this bug.


Note You need to log in before you can comment on or make changes to this bug.