Bug 1462163 - [trello nbkIrqKa] inline/toast notification inconsistency when import quota yaml
[trello nbkIrqKa] inline/toast notification inconsistency when import quota yaml
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samuel Padgett
XiaochuanWang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-16 06:49 EDT by Xingxing Xia
Modified: 2017-06-16 08:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-16 08:32:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
inline-after-import-process-template-containing-quota (77.65 KB, image/png)
2017-06-16 06:49 EDT, Xingxing Xia
no flags Details
overview-inline-successful-message-after-create-from-image-or-template (20.24 KB, image/png)
2017-06-16 06:59 EDT, Xingxing Xia
no flags Details

  None (edit)
Description Xingxing Xia 2017-06-16 06:49:34 EDT
Created attachment 1288313 [details]
inline-after-import-process-template-containing-quota

Description of problem:
When non-cluster-admin user imports quota yaml, it shows toast notification. But when imports and processes template yaml containing quota, it shows inline notification. This is inconsistency

Version-Release number of selected component (if applicable):
v3.6.112

How reproducible:
Always

Steps to Reproduce:
1. Prepare files
$ cat myquota.yaml # quota yaml
apiVersion: v1
kind: ResourceQuota
metadata:
  creationTimestamp: null
  name: myquota
spec:
  hard:
    pods: "1"
    services: "1"
status: {}

$ cat mytemplate.yaml # template containing quota
apiVersion: v1
kind: Template
metadata:
  creationTimestamp: null
  name: mytemplate
objects:
- apiVersion: v1
  kind: ResourceQuota
  metadata:
    creationTimestamp: null
    name: myquota
  spec:
    hard:
      pods: "1"
      services: "1"
  status: {}

2. On web console Import YAML/JSON page, paste content of myquota.yaml, click Create

3. Paste content of mytemplate.yaml, click Create --> choose Process --> Continue --> Create

Actual results:
2 and 3 both shows non-cluster-admin user cannot create quota, but the former uses toast notification, the latter uses inline notification (see attachment) and is kept inline too on overview page [see Additional info]

Expected results:
2 and 3 should be consistent in notification style

Additional info:
Should it be inline/toast notification on overview page?
Comment 1 Xingxing Xia 2017-06-16 06:59 EDT
Created attachment 1288315 [details]
overview-inline-successful-message-after-create-from-image-or-template

BTW, after create from image or template, the success message in overview is still inline like 3.5, is it intended for the user story card? Or it should be toast notification too?
Comment 2 Samuel Padgett 2017-06-16 08:32:13 EDT
This is working as intended. We use a different style notifications because templates create multiple resources. Some might succeed and some might fail. The inline alerts can summarize the results for many objects. Import YAML creates just one resource currently, so it uses the toast notifications and blocks you from proceeding if it fails.

Both templates and creating from a Git source repository use the in-page notifications. We might change this in the future, but currently it's working as designed.

Note You need to log in before you can comment on or make changes to this bug.